WeTek Community Forum
Hi WeTek Fan! :)

Please check our WeTek Closed BETA program: http://www.wetekforums.com/v/discussion/31382/call-for-closed-beta-on-wetek-play-2?new=1

Thanks
MasterChief117

Ubuntu 16.04 Mate & Minimal for WeTek Play 2

QuadbeatQuadbeat Posts: 188WeTek Community Member
edited June 13 in Linux
Hello,

Latest release

21.10.2016

Ubuntu 16.04 LTS minimal - 21.10.2016

What is new:
  • Login with root/wetek credentials is fixed
  • Wi-Fi is working (ifconfig wlan0 up , iwlist wlan0 scan)
  • Bluetooth is working (hciconfig -a , hcitool scan)
  • DVB driver fully functional
  • Added LED's control
  • Kernel synced with latest Odroid changes 3.14.79 https://github.com/theripper/linux/tree/wetek-3.14.y
  • apt-get is fully functional now
Hints:

How to enable Optical/S-PDIF output

echo 1 > /sys/class/audiodsp/digital_raw
echo 2 > /sys/class/audiodsp/digital_codec
echo audio_on > /sys/class/amhdmitx/amhdmitx0/config
echo spdif_unmute > /sys/devices/platform/spdif_codec/spdif_mute

minisatip as full SAT>IP server

Download - minisatip for WeTek Play 2



Old releases

06.09.2016
Username: wetek
Password: wetek

and

Username: root
Password: wetek

How to install it:

Download desired .img file, unpack it with 7zip and flash it to microSD card with Win32 Disk Imager.

NOTE: Be sure that You are running latest WeTek Play 2Android Firmware

Ubuntu 16.04 LTS Mate and minimal builds are based on Odroid C2 code from HardKernel.

Fork of Odroid C2 Kernel for WeTek:

https://github.com/theripper/linux/commits/odroidc2-3.14.y

In case somebody wants to build own:

make wetek_defconfig

make -j4 Image dtbs modules
«1345

Comments

  • NedScottNedScott Posts: 1,123WeTek Community Member
    Very awesome :D


    former WeTek Support team member, now just a friendly volunteer.
  • lmzalmza Posts: 21WeTek Community Member
    Great, thank you for this. My Play 2 is in transit and is on its way.

    Is the DVB-S2 tuner module included in the Ubuntu image for this kernel? Either as a built-in module or as external loadable module? If not, any idea where I can download this DVB-S2 module and what kernel versions are supported?

    I know with Wetek Play, the driver was not opensource but Wetek did make it available as an external module (.ko).
  • QuadbeatQuadbeat Posts: 188WeTek Community Member
    If not yet working, we will make them working :)
  • psidlopsidlo Posts: 15WeTek Community Member
    X and video acceleration (VLC/Kodi) working?
  • QuadbeatQuadbeat Posts: 188WeTek Community Member
    Kodi should be working with acceleration.
  • ozkaradagozkaradag Posts: 585WeTek Community Member
    Excellent, great news.

    Thanks for info sharing.

    Sincerelly...
  • H0nch0H0nch0 Posts: 210WeTek Community Member
    very nice indeed keep us updated on your dvb support :)
  • gonesupergonesuper Posts: 64WeTek Community Member
    Has anyone tried putting mythTv on this with kodi as a front end
  • lmzalmza Posts: 21WeTek Community Member
    Quadbeat said:

    If not yet working, we will make them working :)

    Hi there. Received my Play with DVB-S2 tuner. Unfortunately the DVB module is not included in the Ubuntu LTS minimal image.

    I did see wetekdvb.ko is included in the LibreElec for Play 2, but this is using kernel 3.14.29. The Ubuntu Minimal has kernel 3.14.65+
    wetek@wetek:~$ su - root
    Password:
    root@wetek:~# dmesg | grep dvb
    root@wetek:~# ls /dev/d
    di0 disk/ dri/
    root@wetek:~# lsmod
    Module Size Used by
    i2c_gpio 4304 0
    gxbb_wdt 3419 0
    dhd 864361 0
    cfg80211 472770 1 dhd
    ipv6 375777 18
    autofs4 28145 2
    root@wetek:~# uname -a
    Linux wetek 3.14.65+ #5 SMP PREEMPT Mon Sep 5 15:00:02 CEST 2016 aarch64 aarch64 aarch64 GNU/Linux
    Please could you build a module for the Ubuntu kernel. I had a quick look at the Ubuntu Mate image as well and I also cannot seem to find the wetekdvb.ko module as well.

    Thank you.
  • amsterdamxxxamsterdamxxx Posts: 93WeTek Community Member
    Does Ubuntu goes on a Wetek Hub?
  • AnimaAnima Posts: 1,635WeTek Support Team

    Does Ubuntu goes on a Wetek Hub?

    This version is made for the Wetek Play2
    the hub does have a working ubuntu version yet.

    Best regards

  • messertmessert Posts: 30WeTek Community Member
    Wifi not connect in my device. Have anybody same problem?
  • lmzalmza Posts: 21WeTek Community Member
    Noticed that 8 days ago that dvb was enabled in https://github.com/theripper/linux/tree/wetek-3.14.y device tree. It is built as a built-in kernel module.

    The new wetek_defconfig (line 1331):
    #
    # WetekPlay driver
    #
    CONFIG_AM_DVB=y
    I then built the new kernel successfully which is now at version 3.14.77 and ran

    make modules_install

    I then replaced the Image and meson64_wetekplay2.dtb on the FAT partition of the SD card with the newly built files.

    Ubuntu minimal boots up fine, but the dvb driver still does not load. I do however get a message now with dmesg at boot time:
    root@wetek:~# dmesg | grep dvb
    [ 4.536313] wetek-dvb dvb: Failed to acquire Wetek i2c-1 adapter ...
    Any suggestions on how I can get this dvb driver to load and work properly?

    Thank you.
  • the_ripperthe_ripper Posts: 28WeTek Community Member
    Hello @lmza ,

    pull again kernel and recompile all again, I added changes in defconfig regarding I2C. It was compiling as module but I2C need to be working on boot so tuner/demod can be detected and thats why there is error with "Failed to acquire ........". Regarding DVB module soon will be available.

    Thx.
  • ozkaradagozkaradag Posts: 585WeTek Community Member
    This is a super news.

    Sincerelly...
  • lmzalmza Posts: 21WeTek Community Member

    Thank you @the_ripper.

    Yes, made some progress after recompiling:

    root@wetek:/lib/modules# dmesg | grep AVL
    [ 7.426016] wetek-dvb dvb: Checking for AVL6211 DVB-S/S2 demod ...
    [ 7.430237] i2c i2c-1: AVL6211+AV2011 DVB-S/S2 successfully attached

    root@wetek:/lib/modules# dmesg | grep dvb
    [ 4.897936] wetek-dvb dvb: Found Wetek i2c-1 adapter ...
    [ 4.903041] wetek-dvb dvb: ts0: parallel
    [ 4.907003] wetek-dvb dvb: dmx rst ctl = ffffffc05b68f480
    [ 4.912273] wetek-dvb dvb: asyncfifo rst ctl = ffffffc05b68f580
    [ 4.918191] wetek-dvb dvb: ahbarb0 rst ctl = ffffffc05b68f680
    [ 4.923830] wetek-dvb dvb: uparsertop rst ctl = ffffffc05b68f780
    [ 5.746014] wetek-dvb dvb: Wetek NIM(s) detection in progress ...
    [ 5.749583] wetek-dvb dvb: Checking for Sony CXD2837 DVB-C/T/T2 demod ...
    [ 6.606012] wetek-dvb dvb: Checking for Panasonic MN88436 ATSC demod ...
    [ 7.426016] wetek-dvb dvb: Checking for AVL6211 DVB-S/S2 demod ...
    [ 7.436231] wetek-dvb dvb: Total Wetek NIM(s) found: 1
    root@wetek:/lib/modules#


    , but yes, dvb module still outstanding:

    root@wetek:~# ls /dev/d
    di0 disk/ dri/


    Thank you.
  • the_ripperthe_ripper Posts: 28WeTek Community Member
    @lmza
    I uploaded for you 2 files. Please copy new boot.ini and you have wetekdvb.ko too, so try to insmod it and see if you have dvb adapter.

    https://mega.nz/#!qQcFmKyC!k9q93HcEr3-FcGa5pJlpyFADyk3KTx__UMwnYMVPPFM

    Thanks.
  • lmzalmza Posts: 21WeTek Community Member
    Thank you @the_ripper

    I have tried insmod, but received following error:

    root@wetek:/lib/modules/3.14.77# insmod wetekdvb.ko
    insmod: ERROR: could not insert module wetekdvb.ko: Invalid module format


    modinfo shows:

    root@wetek:/lib/modules/3.14.77# modinfo wetekdvb.ko
    filename: /lib/modules/3.14.77/wetekdvb.ko
    license: Proprietary
    depends:
    vermagic: 3.14.77+ SMP preempt mod_unload aarch64
    parm: adapter_nr:DVB adapter numbers (array of short)


    The compiled version is 3.14.77 and not 3.14.77+. Should it still work?
    uname -a
    Linux wetek 3.14.77 #1 SMP PREEMPT Mon Sep 19 03:42:45 UTC 2016 aarch64 aarch64 aarch64 GNU/Linux


    If it should work I would try and recompile everything again and try again?
  • lmzalmza Posts: 21WeTek Community Member
    B) @the_ripper

    Great work, I have dvb interface now.

    root@wetek:~# ls /dev/dvb/adapter0/
    demux0 demux1 demux2 dvr0 dvr1 dvr2 frontend0 net0 net1 net2


    I do not have a satellite feed where I am at the moment. I will buy another Play 2 and ship it to colleague. Will test lock, etc then.

    Thank you for all the assistance.
Sign In or Register to comment.
© Copyright 2014 - Creative Dreams | Powered by Vanilla
All times are UTC