WeTek Community Forum

screen resolution not recognized - black screen

ccmillsccmills Posts: 4WeTek Community Member
Hi,

My wetek core fails to recognize the 720p standard of my tv so the screen stays black. I have had this issue multiple times in the past and was able to google around for a solution, but I can't find it this time round. I forgot how it was done. I have a macbook. I had to use ssh, or telnet, or something like that to get into the core, change the resolution so i had a garbled screen, but saw something and was able to navigate to the menu to turn on 720p and restart. If someone can help me out with a step by step procedure (noob here), that would be greatly appreciated.

best, cc.

Comments

  • ThrallThrall Posts: 3,321WeTek Support Team
    Try the following command using ssh (if you're using LE or OE)

    echo 720p > /sys/class/display/mode

    You can change the resolutions values to the one you need.

    Best Regards

  • ccmillsccmills Posts: 4WeTek Community Member
    Thanks for your reply @Thrall . I'm not really familiar with how to use ssh. But I tried the following two commands in terminal: "ssh 192.168.1.112" and "ssh wetek@192.168.1.112". Both these commands returned the following error: "ssh: connect to host 192.168.1.112 port 22: No route to host"

    What am I doing wrong?
  • ccmillsccmills Posts: 4WeTek Community Member
    edited February 12
    Uh oh, I used the wrong ip. When I use the right ip with the two commands I get the following error: "ssh: connect to host 192.168.1.139 port 22: Connection refused". And how do I know if my wetek core runs LE or OE? Please help.
  • AnimaAnima Posts: 1,940WeTek Support Team
    That will depend on what you are using.

    If you start your WeTek and it shows WeOS it is android, If it shows Libreelec, then it is running libreleec.
    If you do not know this, Libreelec open automatically Kodi, as it runs natively.
    WeOS will show you an Android interface.

    In Android, if you know your IP address for sure, you can use your PC browser and in the address bar write IPOFTHEWETEK:8008 and an webinterface will appear, showing you an option for screenshot.
    Moving via screenshots you can select other resolution via menu.

    if you are indeed using Libreelec, you just follow my colleague instructions:

    echo 720p > /sys/class/display/mode

    This of course if you had SSH enabled before the problem. If SSH is disabled then I'm afraid you will need to manually install the Operating system again, resetting everything.

  • ccmillsccmills Posts: 4WeTek Community Member
    @Anima Yes! the 8008 and ip thing did the trick. Thanks!
  • AnimaAnima Posts: 1,940WeTek Support Team
    @ccmills

    Glad it is working now :)

Sign In or Register to comment.
© Copyright 2014 - Creative Dreams | Powered by Vanilla
All times are UTC