WeTek Community Forum

"missing kernel or system" when updating from 8.0.2 to 8.2.5

itomicitomic Posts: 47WeTek Community Member
Hi All,

I've got a Wetek Play 2 running LibreELEC 8.02. I've download the latest update file LibreELEC-WeTek_Play_2.aarch64-8.2.5.img.gz from here: https://libreelec.tv/downloads/

I've copied the update file to the Updates folder via Samba share as described here:

https://support.wetek.com/hc/en-us/articles/115004194345-How-to-update-my-LibreELEC-OpenELEC-

I then restart my Wetek Play 2.

It detects the update file, and decompresses it for a minute or two.

BUT, when it comes to attempting to apply the update, I see on the screen an error message that says "missing kernel or system".

It then boots normal... to 8.0.2.

Any ideas what I'm doing wrong?

Thanks,

Ross

Comments

  • itomicitomic Posts: 47WeTek Community Member
    Ah, it was ages ago since I first set this box up. Answering my own question... I did a NAND install, i.e. I overwrote the original Android / WeOS.

    OK, as per instructions at https://libreelec.tv/downloads/ I'll

    "Download the NAND install zip file, unzip it, and copy the files inside over to the root folder of a FAT32 formatted SD card. Power off the WeTek Play 2 and insert the SD card, then Power on while holding the reset button on the toothpick sized hole on the side panel of the device in for 7-8 seconds until LibreELEC installation starts"

    What I don't know is whether this will overwrite my current LibreELEC settings on my WeTek Play 2 box, or whether it will preserve them. I guess I'm about to find out! Will report back.
  • itomicitomic Posts: 47WeTek Community Member
    OK, so I've tried updating LibreELEC using a USB Drive, created using the "LibreELEC USB-SD Creator"... but still no luck.



    So I'm trying again with copying the latest file LibreELEC-WeTek_Play_2.aarch64-8.2.5.img.gz to the Updates folder, then restarting my Wetek Play 2, and this is what I get:



    Can anyone throw me a bone here?

    Thanks,

    Ross
  • AnimaAnima Posts: 1,988WeTek Support Team
    Does the same error happen if you try to update it via settings?

  • itomicitomic Posts: 47WeTek Community Member
    OK, so the instructions for updating via Settings are these:
    Open settings » LibreELEC / OpenELEC
    In System you will have the Updates section
    Select "Update channel" and choose the Main version you wish to update to
    Select "Available versions" and choose the version you wish to update to
    Confirm with OK.
    The weird thing is that I went to attempt the above as the first thing I tried. My system was set to auto-update, but clearly it wasn't auto-updating. So I switched it to manual, but the "Update channel" and "Available versions" sections weren't populated with any content, so there weren't any choices I could make.

    Which is when I attempted more manual method, and ran into the problems I described in my original post.

    BUT now I've gone back to these Settings... the "Update channel" and "Available versions" ARE now populated, and I could perform the updated to 8.2.5, no problem at all.

    Problem solved!

    Thx,

    Ross
  • AnimaAnima Posts: 1,988WeTek Support Team
    Glad everything is now working as intended :)

    Maybe Libreelec server acted up at that time.

Sign In or Register to comment.
Help Center

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

© Copyright 2014 - Creative Dreams | Powered by Vanilla
All times are UTC