How to Nuke buggy WeTV and run aTvHeadend server with Ricardo's WeOS 3.1 fixes

wrxtasy
wrxtasy
Junior MemberPosts: 1,173 edited September 3 in WeTek Builds/ROMs/Updates
WARNING WARNING !
DO NOT downgrade any WeOS 3.x Firmware to any WeOS 2.x or you will brick the Play2 !

Also DO NOT downgrade Android TV 2.2 to WeOS 2.x otherwise expect bricking.

Decided to pull this out of the main thread...

How to Nuke WeTV and run aTvHeadend server with @ricardopvz WeOS 3.1 fixes:
This is all pretty safe, it just patches existing WeOS 3.1 Firmware and removes buggy WeTV in the process.
Those without a TV tuner just flash the .zip Firmware patch and you are finished.

1) Ensure WeOS 3.1 is already installed by confirming in Android Settings > About > Build
Download the bug fixed Firmware .zip file from HERE
Do NOT choose the .zip download option, you want direct download.
Save to USB Stick / SD Card, insert into Play2. Do NOT unzip.

2) To get into Android Recovery to flash the .zip file:
- From WeOS use Android Settings > Device > Storage & Reset > Reboot to Recovery
- Apply update from External > udisk (USB stick) or SD card.
- Select the .zip Firmware file that was previously downloaded.
- Wipe Data / Factory Reset (Recommended if you want a completely clean system)
- Otherwise just do a "Clear Cache"
- Reboot

3) Set correct permissions for the TvHeadend server - this is simple it just looks complicated.
- Telnet (meaning Login) into Play2 using Terminal (Apple Mac) or Putty Click to Download (Windows) programs:
IP address of Play 2 found by Android Settings > Network > WiFi or Ethernet
No Password is needed to Login into the Play2 when using Telnet.
Click HERE for Telnet - Putty Youtube help
(copy and paste - one line at a time)
telnet ip.address.of.play2
mount -o rw,remount,rw /system
chmod 755 /system/bin/tvheadend
mount -o ro,remount,ro /system
start tvheadend
exit
4) Setup TvHeadend server using a Network connected Web Browser on a PC:
http://ip.address.of.play2:9981
Use the Wizard to select and tune TV channels
Configuration > Channels / EPG > Channels > remove (untick) duplicates (remember to save)

5) Install SPMC 16.x.x from the Playstore / Aptoide
SPMC Settings > Addons > MyAddons > PVR Clients > Tvheadend HTSP Client > Enable
SPMC Settings > TV > Configure as you see fit > Enable
SPMC Settings > Video > Adjust Display Refresh Rate > Start Stop
(never enable Sync playback to display even in Kodi - as it will kill Audio Passthrough)
SPMC Settings > Video > Acceleration > Accelerate MPEG2 > Always

TvHeadend server TIPS:
How to add Channel Logos
How to setup external USB recording storage
How to Edit the Channels List
How to setup Audio Passthrough in SPMC/Kodi

SPMC has to be used for TV viewing as you need Amcodec hardware acceleration and Amcodec Hardware deinterlacing. The Android Kodi Krypton TvH PVR Client is unreliable and broken on all Android platforms. Android Kodi Krypton has removed Amcodec Hardware acceleration.

To reinstall WeTV - reflash WeOS 3.1 again from Android Recovery

What Ricardo's fixes gives you:

Bug fixed video playback when using browsers. (should be working)
Netflix 5.1 Audio, even if you only have a AC3 capable HDMI connected Soundbar / TV / AVR
**Android TV Netflix currently broken - fixed real soon.
10bit HEVC video content actually plays properly.
Fixed refresh switching issues during video skipping in Kodi/SPMC when playing back 10bit HEVC (H265) content and during TV Channel changing with TvHeadend PVR.
Telnet root access re-added
Untested as yet: improved Audio, inc SPDIF audio output.
Plus what WeTek should have included all along - a TvHeadend server !
- for a much better EPG and PVR usage ;-)

And if that does not convince you the read...

WeTek Play2 - 4K PVR - HD Audio - Dual Boot - Specs & Reviews

Whew !
«13

Comments

  • Dandroid
    Dandroid
    Thanks, I'm going to update
  • Dandroid
    Dandroid
    I tried android TV ROM first, but now I'm going to try this.
  • bolt12
    bolt12
    Would be nice to hear whether recent apps function still working for you after flashing the fix zip
  • Dandroid
    Dandroid
    Recent apps worked yes. I have tried to root ect but taking longer that expected as my SD card has various file and updates for other box and keeps wiping data....
  • Dandroid
    Dandroid
    edited June 30
    Having had recently apps working, it now does not. I don't know why, I have done any updates or anything. One boot it works, now it doesn't.
    Edit it works now, but....

    I have installed a navbar app, works great, apart from... Recent apps.
  • bolt12
    bolt12
    After you have rooted?
  • bolt12
    bolt12
    edited June 30
    Which navbar app have you installed? Tried almost every from playstore but none worked for me
  • bolt12
    bolt12
    lBut its just an alternative status bar, not the original one from tablets with clock and notifications , or?
  • Dandroid
    Dandroid
    That app doesn't need root tho
  • bolt12
    bolt12
    But for what do you need it ? Its very limited in its function and every button can be used with RC or?
  • Dandroid
    Dandroid
    i like using airmouse.
    Also, it gets me out of apps when stuff crashes etc.

    Also, recent apps has now stopped again.
  • mrgiggsy11
    mrgiggsy11
    I tried this app for quite some time and it is good..
    https://play.google.com/store/apps/details?id=com.echoff.easyswitch
    I recommand to you..
    @bolt12 @Dandroid
  • Gusto
    Gusto
    Grand Master Ricardo
    I want to stay with WeOS 3.1
    For me, there is only one problem that does not work the video in the Internet Browsers.
    Is it possible to make a correction to the video problem in Internet browsers?
  • Matty
    Matty
    edited July 3
    sorry to be a pain but i just cant get any tuners to show in the wizard just IPTV

    When you say telnet in play2 using terminal or putty
    does that mean i need to use a app to telnet on the WP2 OS or off my laptop?

    Thanks
  • wrxtasy
    wrxtasy
    Junior Member Posts: 1,173 edited July 4
    I've just added this extra help for those having issues understanding Telnet.
    When I write (Windows) that mean a home Network connected PC or Laptop running Windows.

    3) Set correct permissions for the TvHeadend server - this is simple it just looks complicated.
    - Telnet (meaning Login) into Play2 using Terminal (Apple Mac) or Putty Click to Download (Windows) programs:
    IP address of Play 2 found by Android Settings > Network > WiFi or Ethernet
    No Password is needed to Login into the Play2 when using Telnet with the Play2.
    Click HERE for Telnet - Putty Youtube help
  • Matty
    Matty
    Thanks again @wrxtasy

    Will try this tonight.

    Did manage to get onto the tvheaded wizard but couldn't find any satellites

    Will try again tonight
  • spinecho
    spinecho
    Hi,

    1st...many thanks for this!

    Just installed this and followed the guide...ok, so far however...I don't have a TV menu item on SPMC, even after enabling "TV" in SPMC TV settings.

    Any help?
  • Dandroid
    Dandroid
    I got it working, but I could get any channels to laid properly I had add my channels as favourites and access them that way.
  • wrxtasy
    wrxtasy
    Junior Member Posts: 1,173 edited July 12
    Configuration > Channels / EPG > Channels

    Press the "Number" column heading to make sure your channel number are in Order and correct. You can also enable/disable junk channels here or even delete them. Remember to Save.

    Then SPMC > Settings > TV > Enable these three:

    - Synchronise Channels Groups with backend
    - Use channel order from backend
    - Use Channel numbers from backend

    Then to synchronise everything again > Clear data (down the bottom)
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Discussions

© Copyright 2014 - Creative Dreams | Powered by Vanilla
All times are UTC