WeTek Community Forum

Can the Wetek Play2 play NETFLIX with Dolby Digital 5.1

JohnWBJohnWB Posts: 26WeTek Community Member
Is it possible to get the Wetek Play2, with the latest update WeOS v3.1 update, to play NETFLIX with Dolby Digital 5.1 through HDMI

Comments

  • wrxtasywrxtasy Posts: 1,221WeTek Community Member
    edited July 2017
    I had to flash one of either two Firmware patches or the ATV ROM - from @ricardopvz to get 5.1 DD Netflix Audio to my HDMI connected DD+ capable 4K TV:

    http://wetekforums.com/v/index.php?p=/discussion/30440/how-to-nuke-buggy-wetv-and-run-atvheadend-server-with-ricardos-weos-3-1-fixes

    http://wetekforums.com/v/index.php?p=/discussion/30398/rom-play-2-marshmallow-android-tv-v2-2/p1

    Both of these are easily done from Android Recovery with a USB stick that has the .zip package update on it.
  • ThrallThrall Posts: 3,321WeTek Support Team
    JohnWB said:

    Is it possible to get the Wetek Play2, with the latest update WeOS v3.1 update, to play NETFLIX with Dolby Digital 5.1 through HDMI

    Yes it is possible.

    You just need to download Netflix App from AptoideTV.
    Go to Aptoide,
    Applications

    Search for Netflix, it should be the version 4.0.4.

    That app supports 4k and 5.1 (if yor AvR support it)

    Note that Installation of other roms Voids Warranty.

    Best Regards

  • willemtwillemt Posts: 9WeTek Community Member
    I cannot install version 4.04, any tips?
  • wrxtasywrxtasy Posts: 1,221WeTek Community Member
    Remove any other installed versions of Netflix you already have.

    Android Settings > Apps > Download > Netflix > Uninstall.
  • cibergciberg Posts: 73WeTek Community Member
    edited July 2017
    I bought the Play 2 today and I am disapointed because one of the main reasons I bought it was to have 5.1 sound on Netflix and it is not working.

    I updated the box all the way to WeOS 3 and downloaded Netflix from Aptoide, I tested version 4.0.4 and 4.0.5 and my AVR does not recognize 5.1 sound.
    The problem is on the Netflix app because there is no option for 5.1 on soundtracks as I have when using Netflix on the PS3.

    What am I doing wrong?

    The AVR works right because in Kodi I have Dolby Digital 5.1.
  • wrxtasywrxtasy Posts: 1,221WeTek Community Member
    See Post #2 of this thread.

    I have a Xiaomi Mi Box with the exact same Android TV Netflix App and can get 5.1 Audio to my DD+ capable 4K TV with that combo.

    Play2 and the same Netflix App = 2.0 PCM Audio only. I too have asked WeTek many times to fix it. They are unwilling or unable.

    A guy called Ricardo comes along and releases an Android TV ROM.
    After giving him some Logs, he patches the Android TV ROM (WeOS3.1) and also patches WeOS3.1 itself and overnight - I like many others now have 5.1 Netflix Audio when used with DD+ TV's / AVR.

    See Post #2 of this thread.

  • cibergciberg Posts: 73WeTek Community Member
    Thanks a lot wrxtasy.

    I tendencially trusted the post from Wetek Support guy (Thrall), but sadly it seems that his solution does not work, and more sad even is that he threatens with void warranty if a alternative ROM is installed.

    It is a shame that they do not fix the bug, I do not know if I will return the box as it does not deliver on its promises.

    I will try your solution tonight, thank you again.

    Will I lose the ability to go back to the official WeOS?
  • wrxtasywrxtasy Posts: 1,221WeTek Community Member
    edited July 2017
    With this Firmware patch below you are not even flashing another ROM. It just debugs and improves on existing WeOS3.1

    http://wetekforums.com/v/index.php?p=/discussion/30440/how-to-nuke-buggy-wetv-and-run-atvheadend-server-with-ricardos-weos-3-1-fixes

    To get back to the original WeOS3.1 with WeTV you just repeat the Flashing process only this time with the WeTek WeOS3.1 .zip Firmware file. WeTek would not even know you have been playing around ;)

    Do not downgrade the Firmware from WeOS3.1 (or Android TV ROM 2.2) to WeOS2.x that is where people have ignored warnings had major issues going from Android Marshmallow back to Lollipop.

  • ThrallThrall Posts: 3,321WeTek Support Team
    With Netflix e version 4.0.4 present on aptoide, 5.1 works. have you tried it?
    We are currently facing some troubles with passthrough so maybe a coincidence when you tried and it did not work. unless there is some incompatibility with your AVR it should work.

    I did not threaten, i just gave a warning. People who fail the installation, damage the devices and in some cases when attempting other procedures they lose the valuable drms. My job is to let you know the consequences. If this happens the warranty will not cover it.

    Best Regards

  • cibergciberg Posts: 73WeTek Community Member
    edited July 2017
    Hi Thrall,

    I tried with Netflix 4.04 and 4.0.5 via aptoide and the app does not show the 5.1 option when choosing soundtrack.

    This excludes AVR incompatibility as it could be that if I could choose 5.1 on the app and the AVR did not detect it, but the app does not even show the option. And the AVR works correctly in Kodi.

    Nobody likes more a plug and play solution than I, but my other choice is to return the box.
  • wrxtasywrxtasy Posts: 1,221WeTek Community Member
    Just flash the Firmware fix. Will likely take you less time than trying anything else.
    I suspect it will be take all of 7 or 8 minutes. :)
  • cibergciberg Posts: 73WeTek Community Member
    I will do that, I was just telling Thrall I have only 2 choices, or the 3rd party fix or to return the device, which I do not want to do as I like it a lot and this is the only problem with it (and a deal breaker for me).

    @Thrall I did not understand when you say "...We are currently facing some troubles with passthrough so maybe a coincidence when you tried and it did not work.".
    This makes no sense to me, as it implies that the passthrough is somehow dependent on a external service and "magically" any other time the option for 5.1 would appear on the Netflix app, sincerely, do not take this the wrong way, but I did not understand it.
  • ThrallThrall Posts: 3,321WeTek Support Team
    edited July 2017
    @ciberg Becuase weTV is causing some troubles with Passthrough.
    After using weTV, you will lose passthrough abilities. It's a but that our team is now working to fix.

    If you attempt to use Netflix after using weTV without rebooting the device, you would not able to have 5.1 that is what i have mentioned.

    Also, have you enabled HDMI on android audio settings?

    On our side Netflix with 5.1 audio is working without problems (unless used afer weTV as i mentioned above)

    Best Regards

  • cibergciberg Posts: 73WeTek Community Member
    @Thrall I do not have a tuner so I never opened weTV, but thank you, now I understood what you meant.

    I do not use HDMI sound, I use SPDIF as it is the input available on the AVR. I have SPDIF enabled on audio settings.
  • cibergciberg Posts: 73WeTek Community Member
    Hi again,

    I tried wrxtasy solution and it did not work.
    I think it is related with me using SPDIF instead of HDMI, although when I choose HDMI as output the option for 5.1 continues not showing.

    I tried more than one Netflix app with no luck, I factory reseted the device and repeated all from scratch and also no luck.

    Now I must conform and hope for a solution in the future, as it works well on Kodi or return the device (it is factory reseted now).

    Did any of you tested with SPDIF?

    Nevertheless thank you for all your help.
  • wrxtasywrxtasy Posts: 1,221WeTek Community Member
    edited July 2017
    I have no SPDIF/Optical equiptment its all HDMI.

    Maybe its only Ricardo's actual Android TV ROM that gives Netflix 5.1 Optical audio output.
  • cibergciberg Posts: 73WeTek Community Member
    Thank you, I will investigate further.

    Wetek, please take notice on this issue.
  • cibergciberg Posts: 73WeTek Community Member
    Just another update that might help if someone is trying to identify the issue.

    I noticed that after a reboot if I have spdif as defined output when trying to reproduce video Netflix crashes. If I go to sound settings first and choose another output, reproduce something in Netflix, then I can go back to spdif and Netflix won't crash anymore. That is why I did not noticed this before.

    After some googling I found other reports of this behaviour in other systems, it happens when Netflix tries to reproduce Dolby 5.1 sound, so it appear to me that this might be a problem on Netflix's side.

    Even with this problem I decided to keep the box because I think I cannot find such great support in other brands as I have had with Wetek.
  • ThrallThrall Posts: 3,321WeTek Support Team
    Thank you for this info. We will try to reproduce this on our side.
    Best Regards

  • WinWizWinWiz Posts: 24WeTek Community Member
    I'm a new to android tv boxes like the wp2 but on PC the only surround formats SPDIF can carry are Dolby Digital and DTS. Aside from those formats, you are limited to stereo.
    As far as i know it's because SPDIF bandwidth is limited, HDMI is the way to go.
  • ThrallThrall Posts: 3,321WeTek Support Team
    Yes. SPDIC is limited on this. It cannot carries Lossless formats.
    If you desire 5.1 on DTS HD or DD+ or TrueHD for instance, you will need HDMI.

    As I can see, Netflix is DD+ (EAC-3) so through SPDIF it will not work.

    Best Regards

  • cibergciberg Posts: 73WeTek Community Member
    Thank you very much, there is a logical explanation after all.

    Sorry for any inconvenience.
Sign In or Register to comment.
© Copyright 2014 - Creative Dreams | Powered by Vanilla
All times are UTC