WeTek Community Forum

Analog AV output

2»

Comments

  • lama0900lama0900 Posts: 138WeTek Community Member
    snafu said:

    Hm.. the whole metal part is 16 mm.

    1st) 1.5mm too short
    2nd) on android, i think, it works
    3rd) openelec doesn't support this atm.
  • MC117MC117 Posts: 3,707Administrator - WeTek Community Manager
    Hi

    Yes, you need a longer cable: https://wetek.com/shop/av-cable-wetek-play

    On Android it's working normally
    OpenELEC, the last version with AV is 5.0.6

    Best regards

  • tweevicktweevick Posts: 11WeTek Community Member
    Sepp said:

    Since WeTek is still doing false advertising and not bothering about a non-funtional AV output at all, the community still has to take care about this on its own.

    So, here I provide you an updated OpenELEC 6.0.3 build with the above described features, terms and conditions, which will let you use your AV output:

    http://ulozto.net/xJ2zpGAC/openelec-wetek-play-arm-6-0-3-cvbs-tar


    If you would like to see your hardware work as advertised with stock firmware and not only with poorly maintained community builds (namely mine ;-), go to Github issue tracker and join the bug report:

    https://github.com/OpenELEC/OpenELEC.tv/issues/4502

    You need a custom rom:
    https://github.com/OpenELEC/OpenELEC.tv/issues/4502
  • lama0900lama0900 Posts: 138WeTek Community Member
    tweevick said:

    Sepp said:

    Since WeTek is still doing false advertising and not bothering about a non-funtional AV output at all, the community still has to take care about this on its own.

    So, here I provide you an updated OpenELEC 6.0.3 build with the above described features, terms and conditions, which will let you use your AV output:

    http://ulozto.net/xJ2zpGAC/openelec-wetek-play-arm-6-0-3-cvbs-tar


    If you would like to see your hardware work as advertised with stock firmware and not only with poorly maintained community builds (namely mine ;-), go to Github issue tracker and join the bug report:

    https://github.com/OpenELEC/OpenELEC.tv/issues/4502

    You need a custom rom:
    https://github.com/OpenELEC/OpenELEC.tv/issues/4502
    Not for WeTek Core, as we're talking about Core!
  • snafusnafu Posts: 7WeTek Community Member
    Thanks a lot for your replies guys. I only just saw them now because of the awesome notification settings of these "forums" -.-
    My bad for taking this away from WeTek Core towards WeTek Play (actually WeTek openelec).
    Great work of re-implementing the AV out but I think I have to return my box.
    AV advertised and not working with current release, the remote is not always responsive (maybe my couch is too far), cumbersome IR remote (logitech harmony) integration, .... It's just too much. I bought this box as a plug and play set-top box for my parents with an old CRT TV.
    Would be nice to fiddle around and maybe contribute to the community but sadly I haven't really got time for that and it's not what I bought it for.
  • AnimaAnima Posts: 1,988WeTek Support Team
    Hello @snafu

    We're very sorry the wetek box did not meet your expectations.
    Indeed openelec stopped supporting AV output in the newer versions.
    You could also try android, as it support AV and has a simple user interface.
    Also has a more plug and play feeling to it.

    Again we're sorry it didn't meet your expectations, and we are always here, and on out support platform, to help with any questions and problems you might have.

    Best regards

  • SeppSepp Posts: 12WeTek Community Member
    Update time :)

    Here, I provide you an unofficial and unsupported build for LibreELEC 7.0.0, which implements CVBS support:

    http://ulozto.net/xcyeDrUK/libreelec-wetek-play-arm-7-0-0-cvbs-tar

    I decided to switch over to LibreELEC, since on one hand, OpenELEC is ignoring this issue anyway, and on the other hand, OpenELEC still does not have a 7.0 release.

    Maybe things might change with the LibreELEC crew, so give them a chance.

    I had to modify the patch for Kodi 16.1, so the old patch file will not work anymore for compiling. Once I have a little bit more time, I'll open a ticket in the LibreELEC bugtracker and post the patch file there. As always, I'll notify you here, that you can join the discussion in the bug tracker.


    Since with this image, you not just make a major version jump, but you also switch suppliers: MAKE BACKUPS!!!!

    From my experience: Migration was extremely smooth. Initially, you'll get some error messages. No actions needed, just give it some time until all the plugins are updated, then everything starts to work on its own again.


  • AnimaAnima Posts: 1,988WeTek Support Team
    Hello @Sepp

    Thank you for your work with CVBS
    The community will sure apreciate it
    Best regards

  • briselbrisel Posts: 7WeTek Community Member
    Does some enigma2 supports now av out?
  • MC117MC117 Posts: 3,707Administrator - WeTek Community Manager
    brisel said:

    Does some enigma2 supports now av out?

    Hi

    No, it doesn't support

    Best regards

  • briselbrisel Posts: 7WeTek Community Member
    Is it planned for some later release maybe?
  • AnimaAnima Posts: 1,988WeTek Support Team
    Hello

    I don't believe this will implement it in the future.
    They dropped that feature because it was causing trouble with other stuff i believe.

    Best regards

  • anteante Posts: 29WeTek Community Member
    edited November 2016
    A/V cable on wetek play work only in android.correct?
  • ThrallThrall Posts: 3,321WeTek Support Team
    ante said:

    A/V cable on wetek play work only in android.correct?

    yes that is correct. Only works with Android.
    Best Regards


  • ThrallThrall Posts: 3,321WeTek Support Team
    Yes it does with 5.0.6. but does not work with recent versions of LE.
    Best Regards.


  • SeppSepp Posts: 12WeTek Community Member
    Hello folks,

    short update: There is LibeELEC 8.0.0 now. This means it would be time for a new CVBS build. B)

    Unfortunately, I did first (non CVBS) tests on one of my WeTek OpenELEC boxes with the official image and - at least for me - there is a severe problem with a memory leak using LiveTV (with TVheadend).

    This makes LibreELEC 8.0.0 more or less unusable for everyday use. I'll see if this problem will be solved. Not until then I will try to provide a new CVBS version. But at the moment it would be a waste of time.


    Cheers,
    Sepp
  • fcmelgafcmelga Posts: 10WeTek Community Member
    Hello,
    i have 2 wetekplay 2 with android ,anda da av cable wetek not work.

    wath is the solution for that??
  • ThrallThrall Posts: 3,321WeTek Support Team
    fcmelga said:

    Hello,
    i have 2 wetekplay 2 with android ,anda da av cable wetek not work.

    wath is the solution for that??

    Which is the length of the trss av cable?

    WeTek Play 2 needs a 17mm Trrs.

    Best Regards

  • tweevicktweevick Posts: 11WeTek Community Member
    If you have the Wetek AV cable and a Wetek Play 1 box, you can get cvbs output with the custom librelec https://github.com/rgenoud/libreELEC-CVBS-binaries wich works fine
  • SeppSepp Posts: 12WeTek Community Member
    LibreELEC 9 is knocking on the door. While LibreELEC 8 was never stable enough (for me) to be worth to update, I did not provide a custom build with CVBS support.

    Now, testing LE 9 beta was somehow successful so far (eventhough there are still some issues), I was starting to implement a patch for CVBS for LibreELEC 9.

    There are very good news! Crawling through the code, I realized, that finally a functionality similar to the patch discussed in this thread is implemented in Kodi now. It is there out of the box, no custom built needed anymore :smile:

    The functionality is somehow limited, since you can only "override", but not define a fallback, but otherwise it works similar to the patch above: When there is a file /storage/.kodi/userdata/disp_cap, this will override any information read out of the drivers disp_cap.

    So to enable CVBS, ssh into your box and type

    echo "576cvbs" > /storage/.kodi/userdata/disp_cap

    After a reboot, the box will go into 576cvbs and HDMI will not be available anymore until you delete the "disp_cap" file.


    So, I'm really happy that after 4 major xELEC versions, and many, many years, this issue is solved for now.



Sign In or Register to comment.
© Copyright 2014 - Creative Dreams | Powered by Vanilla
All times are UTC