WeTek Community Forum

Core Won't Power On - Power Button remains Red

bog37bog37 Posts: 2WeTek Community Member
I was trying to do an OTA update. The Core was interrupted during process and now will not turn on.

When I plug the Core in the power button is red. When I hit the power button on the remote, the core does not turn on and the screen connected does not turn on either. The power button remains red and does not turn blue.

I have tried holding the reset button on the bottom of the machine and plugging the machine in to try and enter recovery mode and the core does not seem to power on.

I have also prepared a recovery mSD card using the instructions posted in the form for doing the manual update and watched the video included with the instructions. No change, the Core seems to be bricked.

Is there any advice or guidance I can pursue please? I would like to get into recovery mode.

Comments

  • AnimaAnima Posts: 1,988WeTek Support Team
    Hello

    If the Blue light does not light up, after an interrupted update process, it is possible no firmware is installed whatsoever. The only thing left to do is to send the device to repair.

    Contact our support team at Wetek.com/contact to start up the process.

  • bog37bog37 Posts: 2WeTek Community Member
    Shoot, thanks.
Sign In or Register to comment.
Help Center

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

© Copyright 2014 - Creative Dreams | Powered by Vanilla
All times are UTC