WeTek Community Forum

WeTek Hub weOS v3.2 - Android 6.0.1

ThrallThrall Posts: 3,321WeTek Support Team
edited October 2017 in WeTek Builds/ROMs/Updates
We're proud to announce the release of WeOS 3.2 for WeTek Hub.


To update your system, simply access your Apps section on the launcher, enter the WeUpdate app and select Online Update.

Changelog:

Apps:
- Update Kodi to 17.4;
- Update Google Apps;
- Update file manager.

Bug features and overall improvements:
- Improved MPEG2 stream;
- Improved Streams at Browser;
- Improved 10Bit HEVC videos playback;
- Added "Auto change language" option at HDMI-CEC;
- Bug fix for Daydream crash;
- Bug fix for LG remote powering on WeTek Hub.
- Various fixes regarding system’s performance and stability.

If you desire to perform a Local update download this file,
https://mega.nz/#!M1YmnRAK!Ra7jvR9kGvJxQ4uNrJDq71yK9W-lUSYS-osSmXIs2w4

You can follow this article to help you apply the local update.
https://support.wetek.com/hc/en-us/articles/115001315785-How-to-update-my-WeOS-locally


IMPORTANT NOTES:
If you are updating from Android 5, all your data will be erased.
Please do a Manual backup of your data, do not use Android Backup feature on Android 5, as it will not work on Android 6.

Please don't downgrade the device from Android 6 to Android 5!
As the filesystems are different, You'll brick the device!


Best Regards Wetek Team

Comments

  • medmexmedmex Posts: 5WeTek Community Member
    Thanks for the update, and "off topic" nice new forum look!
  • medmexmedmex Posts: 5WeTek Community Member
    Security patch August 2016, shouldn't it be updated?
  • ThrallThrall Posts: 3,321WeTek Support Team

    Appreciated :)
    medmex said:

    Security patch August 2016, shouldn't it be updated?

    This is the standard for Android 6.
    medmex said:

    Thanks for the update, and "off topic" nice new forum look!

    Appreciated! :)

    Best Regards

  • ctrlengctrleng Posts: 2WeTek Community Member
    OTA update works. And "off topic" really did not like the new forum look!
  • StimmenhotelStimmenhotel Posts: 17WeTek Community Member
    My OTA Update is crashing WeUpdate, right now I am on 3.1 WeUpdate 2.0.4.

    While writing this:
    - Force-stopped WeUpdate, deleted data, tried again, working.
    Still maybe not all users will check the app settings for deleting data, something seems to be wrong there.
  • Ph8Ph8 Posts: 27WeTek Community Member
    Was able to get the update, but now hub is in “starting/optimizing” apps and the animated “weOS” loop. Been stuck in a loop for about 30-45 min which seems like way too long for an update. Any suggestions?
  • Ph8Ph8 Posts: 27WeTek Community Member
    Ok, the OTA update for some reason just sent my hub into a loop (OS would not load). I downloaded and manually updated via the rest button method and it seems to have worked.
  • PoincarePoincare Posts: 3WeTek Community Member
    Can WT Hub users get a modern update? For example, with Nougut or Nougut-based? Many Android apps need a modern system to run.
  • AnimaAnima Posts: 1,988WeTek Support Team
    @Poincare

    Updates will be available in the future, however, I don't believe an Android 7 update will be possible.
    AS we are dependent on the AMLogic (manufacturer of the SoC) to release the proper tools for us to work. And I don't see them doing it anytime soon.

  • XitroXitro Posts: 3WeTek Community Member
    I'm waiting for a Wetek OS update with the a AMLogic uboot that fixes the CEC/ARC breaking stuff. Any sight on when this update will be there? I have a Hub I can't use right now.
  • ThrallThrall Posts: 3,321WeTek Support Team
    Hi @Xitro Unfortunately we still have no updates on this.
    Thank you for your patience.

    Best Regards

  • XitroXitro Posts: 3WeTek Community Member
    Thrall said:

    Hi @Xitro Unfortunately we still have no updates on this.
    Thank you for your patience.

    Best Regards

    But from your experience, how long does something like this usually take? Be honest with this please. If it is going to take 1 week to 1 month I have at least an indication, if it is going to take 6 months+ then I'm just going to sell the Hub and look for a different device with a different soc. Or I can make a hardware modification to fight this issue. I'm really tired of waiting.
  • ThrallThrall Posts: 3,321WeTek Support Team
    edited May 2018
    As much I would like to give you an estimated time I am unable to do it.
    I can assure you that this issue was already reported. However, we have no way to know how much time amlogic will take to solve this issue.
    Unfortunately, I cannot give you an estimated time.

    Best Regards

  • secuflagsecuflag Posts: 1WeTek Community Member
    Hi all,

    where can I find kernel sources used in this latest release please?

    Thanks.
Sign In or Register to comment.
© Copyright 2014 - Creative Dreams | Powered by Vanilla
All times are UTC