WeTek Community Forum

Brand new > No "Boot from SD" prompt at start

wilfortunewilfortune Posts: 26WeTek Community Member
I think I'm wasting my time asking this, but is there any trick to getting the Hub to boot from an SD card? I've tried multiple capacities / speed ratings, and even though Android picks up the SD card (I can see it in the "Memory"/"Reset" settings), I never see the "Press POWER button to boot from SD" message that I believe I am supposed to see.

Spent all day trying to get this to work. Beyond frustrated.

Comments

  • wilfortunewilfortune Posts: 26WeTek Community Member
    No SD card I try to insert shows up in the File Explorer. If I insert > eject quickly, eventually it pops up. If I try to explore the contents of the card in the File Explorer, WeOS crashes.
  • TheodorTheodor Posts: 126WeTek Community Member
    edited November 2017
    Is your sd card libre elec? (kodi)
  • ThrallThrall Posts: 3,321WeTek Support Team
    What is the filesystem of your sdcard?

    Is the image LibreELEC?

    Try to format your sdcard with this tool
    https://www.sdcard.org/downloads/formatter_4/

    Copy a jpg or png file into it and see if you are able to browse your sdcard and open the file.
    Then try to write the LE image using the LE tool
    https://libreelec.tv/downloads/

    Download the Hub Image,(be sure you select Hub in the device section)
    Download,
    Write.

    Plug it into the HUB (Facing Down since the hub sdcard slot is upside down.)

    Power on your WeTek, wait until you see the message "Press the power button to boot from the SDcard" When you see this message, press the power button on the remote, be sure you are poiting the remote directly to the wetek

    Best Regards

  • wilfortunewilfortune Posts: 26WeTek Community Member
    Is your sd card libre elec? (kodi)

    I did not buy a card to go along with the device, as I had a 16gb card from SanDisk that I wasn't using. It is a A1 card, ~96mbs.

    I have tried multiple versions of LibreElec:
    1. LibreELEC-WeTek_Hub.aarch64-8.2.0.img
    2. LibreELEC-WeTek_Hub.aarch64-8.0.2.1.img
    3. LibreELEC-S905.arm-8.2-8.2.0.1.img (with WeTek Hub dtb.img)
    I have also tried other mSD cards:
    1. SanDisk Ultra 16gb Class 10 A1
    2. SanDisk Ultra 32gb U1
    3. SanDisk Ultra PLUS 16gb U1
    4. PNY 8gb Class 4
    5. Samsung 2gb (3 different cards)
    6. Unbranded 8gb Class 2
    @Thrall

    I appreciate the effort, but I am aware of the instructions. I have done this many times for the MXQ devices I have, as I didn't know until recently that you could simply copy over the updated version of LibreElec and then restart the device to update. So I've been through the LibreElec SD creation tool many, many times in the past year.

    I think that the card slot is defective, unless there is a specific brand or type of SD card that needs to be used.


    I had really high hopes for this device, and maybe that's why I'm so disappointed right now. The MXQ devices run LibreElec without issue, and they are cheap, but I wanted something that could also access Netflix, SlingTV, HBO Now, and Amazon Prime Video. And I liked the idea of supporting KODI and a company with a good reputation.

    I'll have to wait until tomorrow for a response from WeTek, but the first message they sent leads me to believe they are going to make me eat the cost of this device. Guess that's what I get for being honest. Stuck with a device someone forgot to fully check at the factory.
  • ThrallThrall Posts: 3,321WeTek Support Team
    I believe my colleagues are already exchanging emails with you. do not worry as if there is any hardware problem with your device, our team will take care of it.

    Best Regards

  • wilfortunewilfortune Posts: 26WeTek Community Member
    @Thrall
    Would it be worth it to go to the store and pickup a specific mSD card you guys know works?
  • wilfortunewilfortune Posts: 26WeTek Community Member
    I must not have enough "experience" in the forum yet, as I cannot seem to edit any of my posts.

    To be clear, if there is a setting somewhere I could check, or a different version of WeOS or Android Recovery I could install that would fix this, I am open to anything that will resolve this as quickly as possible.
  • ThrallThrall Posts: 3,321WeTek Support Team

    @Thrall
    Would it be worth it to go to the store and pickup a specific mSD card you guys know works?

    No, there should not be required at all. Your device should be able at least to read the sdacard without a problem and not freeze the device.

    If you desire to attempt a restore of the system we can try, but this is probably Hardware issue.

    Power Off your device
    Disconnect your power supply.
    Underneath your Device, you have an update button (Small Hole)
    With the update nail provided in your package, press and hold that update button
    While pressing, connect your power supply
    Keep pressing the button for 10 more seconds.

    After a few seconds the device will boot into the recovery menu.

    From the recovery menu, select

    Wipe data / factory reset.

    This process will erase all your data, but hopefully will also erase and correct some corrupted filesystem you might have.

    After the process is finished, you can select

    Reboot System Now.

    You can follow this video to help you apply the steps i mentioned above,
    http://tutorials.wetek.com/tutorial/257

    Best Regards

  • wilfortunewilfortune Posts: 26WeTek Community Member
    @Thrall
    I tried all that the other day, but I do appreciate your help all the same.

    DHL picked up the device yesterday, which was nice. Saved me a trip to their office.
  • wilfortunewilfortune Posts: 26WeTek Community Member
    UPDATE: The new Hub I've been using this past year is now showing signs that the micro SD card reader is failing.

    For more details, please see this post: https://www.wetekforums.com/v/discussion/31542/things-i-cannot-do-with-my-hub-running-latest-stock-firmware#latest

    I tried my best to not blame the Hub. I know that whenever I plug in a micro SD card with LibreELEC installed into my Windows PC, the OS does not like the card's "hidden" partition. Always prompts me to format it. So the fact that WeOS has struggled with the same card doesn't surprise me.

    But I think the issue within LE is quite telling, as it seems to be happening reliably when the card is being read from (i.e. when loading artwork). After LE becomes unresponsive, usually any button pressed will result in a delayed "click" noise, but nothing else. Occasionally the selection will move along with the noise, but only rarely.

    As I stated in my other thread, this generally happens only after I've played something, or if the Hub has sat for a long time.

    I thought it may be the SanDisk card (I've had to warranty at least one of their cards in the past), especially when you consider the prevalence of fakes in the marketplace. I ordered two new cards from Samsung (sold and shipped by Amazon), and they both exhibited the same behavior as the SanDisk card.

    As I stated in my other posts, my current Hub would seize up infrequently enough for me to not take the issue seriously. I chalked it up to the box overheating most of the time. Given that I've tested multiple builds of LE and multiple micro SD cards, and that my first Hub had a reader that wouldn't function at all, I feel reasonably confident that my current Hub may have a reader whose defect grew worse over time. I think WeTek may have at least a slight quality control issue they need to sort out.
Sign In or Register to comment.
© Copyright 2014 - Creative Dreams | Powered by Vanilla
All times are UTC