WeTek Community Forum

Recovery for Wetek Hub

NatanNatan Posts: 1WeTek Community Member
Holding recovery button for more than 10 seconds with recovery files on the MicroSD card doesn't do the trick.
Is there any other recovery procedure for Wetek Hub?

Comments

  • ThrallThrall Posts: 3,321WeTek Support Team
    Could you let me know the problem?
    What are the files you're using and what was the version you were using before starting the installation?

    Best Regards

  • Sw333tSw333t Posts: 4WeTek Community Member
    Hi, i've installed LibreElec on the Wetek Hub, but i do not like it. How can i go back to the default OS?

    Best Regards,

    Mark
  • ThrallThrall Posts: 3,321WeTek Support Team
    Try the following.

    If does not work, let me know the version of the libreelec you used.

    Let's attempt a Clean Installation of the OS, you just need to follow these steps:

    You need to download these files:
    https://mega.nz/#F!w15HUDJC!6Jt9RWRTr1S_newLpGArHw

    Extract it until you get 4 files listed like this (Do not need to be in the same order)

    .zip file
    dtb
    factory_update_param
    recovery

    Copy them to a formmated (FAT32) SDcard

    After you have copied the files to your SDcard, follow these steps:

    Insert the SDcard with the files in your device.
    Power Off your device
    Disconnect your power supply.
    Underneath your Device, you have an update button (Small Hole)
    With the update nail provided in your package, press and hold that update button
    While pressing, connect your power supply
    Keep pressing the button for 10 more seconds.

    After the 10 seconds the installation will start automatically.

    You can follow this video to help you apply the steps i mentioned above,
    http://tutorials.wetek.com/tutorial/9

  • Sw333tSw333t Posts: 4WeTek Community Member
    Thanks for your quick response. I've downloaded the files and extracted them on a sdcard (fat32 formatted).

    I've tried several times, but the Hub won't start in the recovery mode. Do i have to release the update button after 10 seconds?

    Best regards,

    Mark
  • Sw333tSw333t Posts: 4WeTek Community Member
    Thrall said:


    If does not work, let me know the version of the libreelec you used.

    It's LibreELEC 8.2.3 with Linux kernel 3.14.29
  • codesnakecodesnake Posts: 744WeTek Community Member, Developers
    @Sw333t Try to remove recovery.img from your SD card and try again.
  • Sw333tSw333t Posts: 4WeTek Community Member
    I tried the same process again, but with the recovery.img from the LibreELEC install and this worked. But it took alot of time before the install took place (i went to do the dishes inbetween, so i can't say how much time it took).

    Now it's back to weOS.

    Thanks all for your help.

    Best regards,
    Mark
  • jstobernjstobern Posts: 1WeTek Community Member
    Does anyone know why the mega.nz link is broken? I have a Hub that I would like to do this process on but I can't download the linked file. Is there a new link?
    Thanks.
Sign In or Register to comment.
© Copyright 2014 - Creative Dreams | Powered by Vanilla
All times are UTC