WeTek Community Forum

Things I cannot do with my Hub running latest stock firmware

wilfortunewilfortune Posts: 26WeTek Community Member
Ordered according to severity of issue:
  1. Use the OS without first obsessively closing any unnecessary background app, and disabling as many apps as possible
  2. Stream anything reliably with DirecTV Now
  3. Stream anything in HD with Amazon Prime Video
The first issue is extremely frustrating. I don't even want to use the Android portion of the device because of it, and I find it very hard to imagine anyone else trying to sludge through it the way I have been. The Hub I have now arrived with WeOS ~v2, so it was obviously a little older, possibly even a return. I did have the same trouble with WeOS on the Hub I returned that had a bad mSD slot (which arrived with WeOS 3.2), so I am left feeling like WeOS on any Hub is virtually useless.

I feel pretty hamstrung by this whole mess. If I want to try and use an alternative OS to get the box functioning the way it was advertised, then I am going to have to install a firmware that will void my warranty.

Thankfully, LibreElec only crashes occasionally, and runs well most of the time. But I didn't buy a WeTek product for LibreElec; I paid more for the Hub because I was led to believe it was one of the best compact Android boxes on the market, capable of running the Android apps I would need to eliminate my computer from the streaming equation.

Part of the problem is that WeTek put too little RAM in the Hub to run Android reliably. Maybe the only thing to do now is return the Hub and wait for WeTek to improve the Hub's specs.
You do not have permission to view polls.

Comments

  • ThrallThrall Posts: 3,321WeTek Support Team
    HI,

    1) Actually, the hubs are shipped with Android 5. Only the most recent baches come fully updated.
    We can agree that hub can sometimes have some performance problem, but you as you know, Hub has only 1Gb of ram, and having your device with some applications and many background apps running is obviously not optimal for performance with 1Gb Ram.

    2) It might not depend on our device but the app instead. Could you give more details about the

    3) It should work in HD. Which version you're using?

    I believe you have the minimum internet speed to have HD quality?
    Can you let me know the speed you get on the hub?

    Best Regards

  • wilfortunewilfortune Posts: 26WeTek Community Member
    @Thrall

    1) While that makes sense, you don't ship the boxes with a simple way of managing background apps. There is no button to view and then close apps like on most Android devices. Aside from that, even using a 3rd party app killer like "Advanced Task Killer" fails to actually prevent the app from continuing to open. Even apps I force close will auto-start upon rebooting the device. YouTube, as well as many other Android apps, run in the background regardless of how many times I try to kill them / force close them.

    You can't make the argument that the consumer is at fault for buying a device with too little memory when you're advertising this as a fully functional Android box, capable of running the most popular apps with ease.

    2) I have tried all the versions of the aforementioned troubled apps, both from the Play Store and Aptoide. Aptoide's version of DirecTV Now will play streams, but they stutter horribly. It is also a dated version of the app, with fewer features, meaning I can't tell it to not autoplay a stream upon start. I also can't get the stream to go fullscreen and omit all the other details / options (such as the Home, Shows, etc buttons).

    As for Android Prime Video, the version of the app from Aptoide is sluggish, and very inconsistent, but after a minute or two, the video will play somewhat reliably. The video often looks as though anti-aliasing has been disabled, so any lines are jagged. I feel like that probably isn't the case, and it just poor upscaling of a reduced quality stream.

    I don't think any of the apps from the Play Store work at all. I think the only ones I have been able to get to work (HBO Now and Netflix), have come from Aptoide, which makes me VERY uneasy. Afterall, with the Amazon Prime Video app, if the person compiling that app wanted to, they could implement an exploit and order something with my account. Super F'ed up that we have to resort to untrustworthy sources when that isn't described ANYWHERE in the marketing on the primary product page for the Hub.

    3) I have 150Mbps down / 50Mbps up, more than enough to stream video, and I can confirm that my network connection has not been saturated during the attempts I have made to use the aforementioned services. After giving up on the Hub, I can reliably access DirectTV Now's web stream in HD without issue. Bear in mind that the Hub is connected to the same Network Switch as the computer that can connect to the DTV Now web stream, and that other apps do not suffer from the same performance degradation.

    I even went as far as to plug the Hub directly into my modem, which wasn't an easy feat, and it did not improve anything. I can provide pics/vidoes later, but I am now late for Thanksgiving dinner after having conducted another thorough round of tests, losing yet another half day to WeTek products :(
  • wilfortunewilfortune Posts: 26WeTek Community Member
    Now it won't power down anymore if I am running Android. I need to return this..
  • ThrallThrall Posts: 3,321WeTek Support Team
    We do apologize for the bad experiencing you're having.
    We understand your comments. But unfortunately, we cannot help you regarding the DirectTV as far as we know it can also be a problem with the app as like other streaming apps like Netflix Hbo as you said works.
    Could you also let me know the amazon prime version? There are more than one on the Aptoide.
    And we never had problems with Amazon Prime Playback.

    We do have an application killer.

    You just need to press and hold the Ok button to bring up the app switcher then you just need to select the apps you desire to kill and press and hold the ok button.

    To attempt to increase performance, you can download the classic launcher.
    Open AptiodeTV store, and search for WeOS.
    Download it, install it, and after it is installed, press the home button for be given the option to select between the two launchers.

    Best Regards

  • wilfortunewilfortune Posts: 26WeTek Community Member
    @Thrall

    1) There are more than one on the Aptoide.

    Actually, no there isn't. Not the Aptoide TV app that comes with the Hub. The only version I can find in there is 3.0.95.33301, and after extensive testing using apps from the default Aptoide app, I can't even play video from a single one of the I tested.

    Which version of the app do you recommend? Do I need to turn simulated-Wifi On or Off?

    2) I tried practically every version of the DirecTV Now app there was in the other Aptoide market. None of them functioned at an acceptable level, however, the very first version looked promising if not for the fact that the device apparently isn't reporting my location correctly.

    Between DirecTV Now and Amazon Prime Video, I must have tested around 40 apps today.

    3) Press/hold the OK button to close apps

    You can also press the Home button to accomplish the same, and from many more places. The only place that your method works is if I am highlighting the 1st entry in "Story".

    All that aside, you aren't correct. That does not "kill" the app. If I go and look at Settings > Apps, every app I "close" from the Recent Applications menu is still running in the background. And if there are enough apps still running in the background, the device becomes unstable/unresponsive.

    4) Classic Launcher to improve performance

    Nope. Didn't do squat to improve things. The only thing that really improved the device so that it wasn't completely unresponsive or constantly crashing was to disable many of the standard Android apps, such as Camera and Google. Without many of those disabled, the device might as well have been powered off.
  • wrxtasywrxtasy Posts: 1,221WeTek Community Member
    edited November 2017
    Question, why did you even buy a WeTek Box to try and get HD Amazon Prime Video in the first place ?

    Amazon simply do not allow reliable Android TV - HD Amazon prime video streaming on anything other than their own Hardware or carefully selected TV's / Bluray Players / NVIDIA Shield.
    They really lock down which hardware devices their App works properly on and WeTek do not make their list of Approved streaming devices.

    Android TV - Xiaomi Mi Box owners are in the same boat - any attempted workarounds for Amazon HD streaming should be considered hack's and simply will be unreliable long term or not work at all.
  • wilfortunewilfortune Posts: 26WeTek Community Member
    @wrxtasy

    Point taken, but Amazon has been making it easier for Android users to get Prime Video. Used to be that you had to get it through their app store, or sideload it. Given that trend, maybe in time it will work with the Hub.

    ***

    Perhaps I'm blowing all of this out of proportion. I don't think I'd be as upset about it if I hadn't already spent so much time trying to get the first Hub they sent me to work. There's also the added pressure of whether or not I can even return it now, as I don't know when the 14 days "officially" started, given the two delivery dates. Mostly I'm mad that these damn little boxes keep beating me. Normally I'm getting paid to grind away at a tech problem. This is just extremely frustrating.

    I can see why WeOS would crash if it was running out of RAM, so that doesn't surprise me so much. But what about LibreElec? Is it normal for that to freeze up? I've had that happen quite a few times now.

    I don't recall Disabling apps in the last Hub I had, only force-closing them. So I can't be certain if the performance issues I had with that would've be resolved with the steps I took with my current Hub. What I'm getting at is, could this box have bad RAM chips? Or is that just par for the course when it comes to a 1GB Android box, regardless of manufacturer? I can't see how someone, with as many apps installed as in the pics on the product page, could have a functional device unless they Disabled apps and also force-closed others when not in use.

    Anyway, I have no idea what I should be expecting, given that my expectations coming into this were waaay off compared to where I'm at right now.

    @Thrall

    Thanks for answering my questions / absorbing my frustration as best you could. I have a lot on my plate right now and I wanted this to make my life a little easier, not complicate things and soak up a bunch of my time in the process. I shouldn't have taken any of that out on you though, so I apologize.

    At this point, I just want to know if the freezing/crashing is normal, and if so, is there anything I can do to improve it. I won't be able to replace all my streaming in one box just yet, but the Hub does run LibreElec well when it isn't locking up randomly. I use that more than anything, so at least there's that.
  • wilfortunewilfortune Posts: 26WeTek Community Member
    For anyone else that is having trouble with DirecTV Now, upon further investigation, apparently DTV has dropped support for all devices running Android TV in/around August. This might possibly be due to an upcoming feature release (Cloud DVR). Alot of people on the ATT forums are pissed off about it.

    It also seems like the same may be true for APV. Whether sideloaded via Amazon Underground or installed from Aptoide TV, the app worked fine for many people, up until recently. Maybe as recently as when the app was officially released in the Play Store.

    ***

    I'll try debugging LibreElec to see if the freezes I've run into are hardware related. Sorry again for being so impatient and aggressive.
  • wrxtasywrxtasy Posts: 1,221WeTek Community Member
    edited November 2017
    Bloody Android Apps and market segmentation.
    Everyone wants their own dedicated streaming service and hardware to go with it. Disney is another example. And its only going to get worse I suspect.

    No wonder Netflix are spending in the order of $8 Billion dollars to make their own Original content.

    For LE I suspect you have a slow microSDHC card, that is know to cause freezing problems.

    I only recommend using the Samsung EVO's, Sandisk or Lexar Class 10 U1 microSDHC varieties for LE AMLogic because they have decent 4K random R/W speeds which is most important when using LE Kodi.

    1GB of RAM for any Android OS really is resource constrained on the Hub. It will be continually doing low level maintenance and garbage collection most of the time if you try and run and switch between multiple Android Apps. 2GB RAM is much better.

    Only thing I can think of is in Settings > Developer options (7 clicks of the Settings > About > Build text) there is a section to limit the number of Apps simultaneously running. That may help.

  • wilfortunewilfortune Posts: 26WeTek Community Member
    wrxtasy said:

    Bloody Android Apps and market segmentation.
    Everyone wants their own dedicated streaming service and hardware to go with it. Disney is another example. And its only going to get worse I suspect.

    No wonder Netflix are spending in the order of $8 Billion dollars to make their own Original content.

    I was on the fence for a very long time about Android boxes. Tried Minix before, but those all fell on their face because their kernels weren't available to the public, so they couldn't survive the transition to HEVC.

    I think that was MediaTek or some other chip/board manufacturers fault though, but it highlighted the fact that any box you buy puts you at the mercy of many different parties, none of which have a vested interest in providing you with a solution that exceeds your warranty period.

    Anyway, I was blow away by what could be done for $40 with the MXQ Pro's I got for my Mom. A third less than the Minix devices, yet they could handle HEVC. Felt like industry as a whole had made a lot of progress.

    I guess my expectation was that for roughly twice the money of one of those devices, I would get to run the Android apps that the crappy "DroidBox"/"MBox" OSes couldn't handle. I knew better than to believe Android with only 1gb of RAM would be fully functional, but WeTek offered free shipping for Halloween. After a year of watching WeTek / the Hub, that deal moved me off of the fence.

    It seems like the only way to go is to spend the money on a NUC. Almost the same footprint, but with upgrade friendly components. Not nearly as attractive, and they do have all their own faults (Win7, for example, is apparently a really nightmare); however, it still seems like that is the only way to replace all streaming/HTPC needs in one, small-footprint solution.
    wrxtasy said:

    For LE I suspect you have a slow microSDHC card, that is know to cause freezing problems.

    I only recommend using the Samsung EVO's, Sandisk or Lexar Class 10 U1 microSDHC varieties for LE AMLogic because they have decent 4K random R/W speeds which is most important when using LE Kodi.

    The card I am using currently is..

    Sandisk Ultra 16GB Micro SDHC UHS-I Card with Adapter - 98MB/s U1 A1 - SDSQUAR-016G-GN6MA

    I knew that the speed of the card would affect the loading time of LE, so I opted to use the fastest one I had available. I did put it through several re-writes/formats trying to get the first Hub to work, so it is possible I may have damaged it a little. I don't think I was that rough on it though..

    I will have to get into debugging LE to know for sure. Hopefully something turns up there and I'll report back if it does. Dealing with network performance issues I uncovered recently, so it may take me a few days to a week.
    wrxtasy said:

    1GB of RAM for any Android OS really is resource constrained on the Hub. It will be continually doing low level maintenance and garbage collection most of the time if you try and run and switch between multiple Android Apps. 2GB RAM is much better.

    Only thing I can think of is in Settings > Developer options (7 clicks of the Settings > About > Build text) there is a section to limit the number of Apps simultaneously running. That may help.

    I didn't even know you could do that! What does the OS do when it wants to open an app, but the open-app quota has been reached? Not open the app or close another app to free up a slot?
  • StimmenhotelStimmenhotel Posts: 19WeTek Community Member
    I can completely understand why you are disappointed.
    I use the hub mainly for libreelec and only now and then I use android for streaming with shared account. (

    This "every now an then" mostly means, I update the android part, check if netflix is working and switch back to libreelec.
    But not today ... I wanted to watch a movie, and well ... Nothing worked on WeOS 3.2... (At least not the Android TV app)

    Checking the code, the atv app is not supported by normal android (tablet mode) anymore ...
    Since the OS is lagging like hell on the hub, I decided to try the ATV Build, based on WeOs 3.2.
    Netflix ATV sideloaded from apkmirror is working.
    But again ... the OS is much to slow/overloaded for running smooth ...
    Disabled nearly every app I was able to within android helped a little.
    And limiting background apps no none, enabling some developer settings for using the gpu, disabling animations, etc.

    Instead repeating audio glitches, stutters and very bad performance...
    I now archived nearly no audio glitches, just a few stutters and a bad performance!
    Nice! I can use Netflix again! :wink:

    I thought I could buy the hub for streaming network, that works fine.
    But to be able to use netflix was the deal about the more expensive box at all.
    I even wanted to wait for the new TV-Box that was announced beginning ... 2017? 2016? You know, flagship of the hub and play2. I think it was play2s?

    But well ... I think I will stay with the Hub/Libreelec combi right now.
    There is even a netflix addon in the making, that hopefully arrives in time for the hub...
    But as long as wetek somehow don't get a decent android box that keeps the promises they made ... I will stay away from another wetek box.
    Most of the things I make right now, I was able to do with my mk808+ stick too. Just not that fast as I can do it now. (Libreelec part)

    Of course, it is not completely the fault of wetek.
    Android gets heavier, streaming provider blocking all devices they don't trust/get money from/... (whatever)

    All in all a really bad user experience... And I wasn't fast, buying the hub. It was really promising when it was announced. Openelec with direct AML support, nice and open chipset, etc.
    But then the remote and only 1GB ram, the latter makes the difference here.

    I wrote more than I wanted to, but I think I just wanted to get over with it.
    PS: Just saw, the play2 supports dvb-t2 but no info about freenetTV if I it correctly.
  • wilfortunewilfortune Posts: 26WeTek Community Member
    @Stimmenhotel

    I just bought a MXQ with 2GB for my grandpa, so I am very curious to see if the additional RAM makes a difference.

    I feel your pain. Tried to watch HBO Now last night and it stuttered to the point where it was unwatchable, and that was only after Force Closing many background apps (speaking of which, why in the hell does Amazon Prime Video always load in the background at startup??). The app appeared as though it had updated itself, so that may have had something to do with the performance issue.

    Libre is becoming less useful. Seems to happen when keying through menus (e.g. items in "Recently Added") or after several hours of playback. Only way to recover is to pull the power cord.

    Wondering if the box is overheating. I'll have to rig up a ~60mm fan or something to test the theory. Not seeing anything useful in the debug logs so I don't know what else to do as this point.
  • ThrallThrall Posts: 3,321WeTek Support Team
    hi @Stimmenhotel We do understand your side. But unfortunately, the Netflix AndroidTV app stopped working due to Netflix restrictions and not from any WeTek Problem. Netflix has their own decisions that unfortunately come to this situation. And we do apologize for this. The only Netflix available is for Android OS that can be downloaded from AptoideTV Store
    Applications » Multimedia » Netflix 5.31 (The one present in this directory), Note that before you install this one, you need to uninstall all the previous ones installed.

    We also understand that the 1Gb ram can be a handicap to the hub, which should be enough only for some streaming apps, but for some moderate usage, 1 Gb RAM can be indeed limited, and the tips is to limit the number for applications and configurations like Kodi skins and library thumbnails (if have it)

    The data stored on the hub.

    You can also try to use WeOS Classic launcher which is a more light launcher.

    For this go to AptoideTV store and on the search bar, type WeOS.

    Download it.

    Once installed, press the home button and select Classic Launcher. On can select it for a temporary usage to see how it works. When You select "Just this time", you will always be prompted to select the launcher everytime you press the home button. If you like the performance, you can select to be used "Always", and you will no longer be asked to select the launcher.

    This can be also changed on
    Menu
    More
    More Settings
    Home

    Best Regards

  • wilfortunewilfortune Posts: 26WeTek Community Member
    I feel like I read this in the ATV thread, but I wanted to add (for posterity's sake) that WeOS is much more useful when there is no SD card plugged in, at least in my case.

    If this thread is any indication of how I've felt about the WeOS on the Hub (with its limited RAM), it should come as no surprise that I've rarely ventured over from LibreELEC. On a few recent occasions, it was completely unusable (far worse than it started out). "Oh well," I thought, "guess it's going to die soon."

    More recently, I've been dealing with an injury, and spent 4-6 weeks convalescing in bed. To help pass the time, I had LibreELEC running on the Hub for entertainment. I was only forced to get up to pull the plug on the Hub once or twice a week, and as irritating as that was becoming, it was tolerable.

    Within the last week and half, the issue became unbearable. I could not play anything and then return back to the main menu. It would always freeze, particularly when moving from "tile" to "tile" (in the default skin, Estuary) as the background changes.

    At that point, I was pretty certain that I would have to file a warranty claim and have yet another box sent out. But I stopped myself, and decided it would be worth going through the hassle of testing out a few different LibreELEC builds. Afterall, I would either be out a media box ("killing" a TV during the interim), or I would have to spend more money on a new box. None of the boxes I've ever purchased from Amazon are still available now, and I don't like the uncertainty involved in purchasing something new that may or may not allow dual-boot with LibreELEC. I would not want to shop anywhere else for an Android box, as I often take advantage of the free, same-day shipping.

    Anyway, the new ROM I tried "fixed" a major issue with the Wetek Pro remote (where only the keyboard-side and pointer worked), so I was excited by that. But the primary issue persisted. That brings us to today.

    I already had the warranty request filled out in Wetek's Support Center, when it occurred to me that I hadn't ruled out the SD card as the source of the problem. The card was practically brand new when I wrote LibreELEC to it for my Hub, and SanDisk generally has a decent reputation. Not the first thing I thought of, obviously. As I don't have a new card handy at the moment, I thought it would be easy enough to pop the card out of the Hub, and try WeOS.

    I couldn't believe it. I was expecting to have to pull the plug on it like I did the last time I tried WeOS, but I was able to navigate around just fine. Not buttery smooth, but responsive enough that I didn't want to kill myself (as has always been my experience with WeOS). Netflix loaded, and although it took five minutes or so, eventually I was streaming in at least 720p (if not 1080p). I could do without the stuttering when the quality increased, but worlds better than when I was force-closing apps like my life depended on it.

    I am going to buy a Samsung mSD card this time around (vs SanDisk), and will report back if that fixes the issue. If it does not, then I suspect I am dealing with yet another Hub with a defective SD slot (and Wetek has some serious quality control issues to sort out). @Thrall, as you have been so helpful in the past, do you know if I will have to pay for return shipping if that ends up being the case?

    In any event, if you find yourself wanting to destroy your Hub because it seems unresponsive or unusable, see if removing any attached storage helps.

    While not a perfect solution, depending on where you store your Hub (or how often you need to have directly attached storage), it might just save you a little money and frustration.

    I do not feel like it is the right time to buy an Android Box. Too many of the same options, rebranded and sold by different vendors. It is hard for me to have any faith or confidence if vendors only carry a product for a limited time, and seem to all the world to be shuffling the same chips into different shapes of molded plastic. Adding something as useless as an LCD screen to these sort of items is proof of how stagnant the market has become.

    And they're all running outdated software. The only Oreo flavored box I've found comes with a Rockchip SoC. I won't buy another Rockchip device, as my first Minix was Rockchip-based and became obsolete the moment official ROMs stopped being released. I don't think I was ever able to find a usable custom rom for it, and I believe this was due to Rockchip not releasing their kernels to the public. That left a lasting impression on me, one that will likely never go away.
  • wilfortunewilfortune Posts: 26WeTek Community Member
    UPDATE: No luck with a new SD card :(
Sign In or Register to comment.
© Copyright 2014 - Creative Dreams | Powered by Vanilla
All times are UTC