WeTek Community Forum

Wetek Core not working Reset?

torontopaultorontopaul Posts: 83WeTek Community Member
Nothing is working on it. I cant find weplayer on aptoidetv to reinstall since only kodi 16 works on it. Weplayer wont launch, kodi just restarts new and wont accept my Urlresolver account. So I cant use regular kodi, so it needs a kodi build. Where can I reinstall weplayer or a kodi build on wetek core?
I guess I will need to reset box and apply all old updates.

I have been having issues with my new wetek play2 hybrid that i just started using. No weplayer and kodi only works with certain addons sporadically. I am getting frustrated after Ive been pushing Wetek brand on everyone for the last several years.

I have spent about $400 on two boxes that stopped working. One brand new and the other barely 2 years old.

Comments

  • torontopaultorontopaul Posts: 83WeTek Community Member
    Oh and neither will work on my new LG tv because of DRM HDCP copyright encryption it wont allow wetek to even connect it says no signal. Works fine on my old 1080 tv
  • AnimaAnima Posts: 1,866WeTek Support Team
    WePlayer exist only to supress some flaws that Kodi 16 had regarding AMlogic devices.
    With the update for Kodi 17 such flaws were removed and WePlayer made no sense to have anymore.
    You just need to update your Kodi version via Playstore, or manually.

    Now, you might find that some of "yours" add-ons might not work, probably because they are outdated, and just like Kodi needs to be updated, add-ons also need to be updated.

    Kodi 16 add-ons will not work on Kodi 17 and vice-versa.

  • torontopaultorontopaul Posts: 83WeTek Community Member
    Regular kodi wont work no matter the version. Weplayer has always worked but something made it stop launching yesterday. Ive tried playstore and aptoidetv like wetek has instructed. Kodi only works if i use weplayer but i cant find it anywhere. Already reinstalled different versions of Kodi but they dont work.
    It seems like all the DRM HDCP encrption is also causing problems which makes no sense since wetek devices are supposed to have DRM license. Now my tv wont work with anything since it had a red flag of DRM HDCP violation. Even netflux wont work. I have to keep switching hdmi ports abd cables and turning tv off and on. Now only 1 port will work with my regular cable box! I guess I need to buy new cables and get a HDCP passthrough splitter.

    I wish i could just uninstall reinstall weplayer ir kodi but its not an option anymore. My playstore wont work either now. So reset is my only option.

    What are my reset options? Which is safer?

    I know there is the reset button on box, reset on wetek menu, backup and restore option that would be pointless.

    Any other reset or upgrade options?
  • AnimaAnima Posts: 1,866WeTek Support Team
    If you are using an HDMI splitter, right there is the reason your HDCP might be acting up.
    Most of those splitter are considered a violation for the HDCP, that is why you get no image.

    WePlayer is Kodi, and there is no reason for it to work better then kodi at this day and age.
    If you factory reset your device WePlayer should be installed by default if you wish to use it so badly.

    Seem to me your setup, might be the grand cause of your despair. Try connecting your device to your Tv directly to find out if the problems persist.

Sign In or Register to comment.
Help Center

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

© Copyright 2014 - Creative Dreams | Powered by Vanilla
All times are UTC