WeTek Community Forum

Pro Remote - Only Air Mouse works (LibreELEC)

wilfortunewilfortune Posts: 26WeTek Community Member
None of the other functionality of the remote works:
  1. "Universal Remote" - RF Signal Learning
  2. Power
  3. Arrow Navigation
The remote that came with my Hub is beginning to have trouble with certain keys, so I thought this would be a great replacement. I figure that I may need a new remote.conf for LibreELEC, but I am disappointed that it cannot learn the signals of other remotes. That was its main selling point for me. It seems to detect/learn the signal, but nothing happens when I press any of the buttons I have "taught" it.

No new updates to WeOS in ages or any new products besides this remote. Are you guys going out of business or something? Are the instructions for the remote wrong or is there a way to update the remote to make it function as advertised?

I bought this through Amazon despite the 1-star rating, hoping I could bring up the rating for you guys. Looking more like something I will have to echo, instead.

Comments

  • wilfortunewilfortune Posts: 26WeTek Community Member
    EDIT:
    I shouldn't have said "nothing happens". When I press a button I have taught the remote, the LED at the top blinks. But the desired action does not occur.

    I have tried "teaching" all of the top "function" keys and the power button. Just trying to get it to turn on my TV and Soundbar. If it could even just do that, I would be much happier.

    I'm fairly certain a new remote.conf made specifically for this remote will fix the other issues, but I have no idea where to find one.
  • wilfortunewilfortune Posts: 26WeTek Community Member
    EDIT2:

    In trying to fix my Hub, I installed a different build (the "temp_sensor_disabled" version found here) and viola, both sides of the remote now work!

    I don't know if this matters, but the remote's USB receiver was plugged in during the installation process of LibreELEC.

    Is there a Wetek Team Member who can comment on how I might be able to get the other functions of the remote to work (particularly the learning functions)? I've followed the instructions to the letter, but I am still unable to control other devices.
  • AnimaAnima Posts: 1,956WeTek Support Team
    Please take a look at our helpcenter page if you haven't already.
    link here: https://support.wetek.com/hc/en-us/articles/360000602069-Setup-Pro-Remote-to-use-with-other-devices

    Sometimes it can be tricky, but instead of pointing both remotes straight, try pointing more close to the blue power button.

  • wilfortunewilfortune Posts: 26WeTek Community Member
    THAT WORKED!

    Perhaps add that little tidbit (about pointing at the blue power button) to the instructions? I swear, it acted the exact way you'd expect it to when I was programming it before. The light would blink, and then when I pressed the button on the "source" remote, it would stop blinking.

    I will write a review on Amazon explaining the proper way to program it for those that are having trouble. Thank you so much!
  • AnimaAnima Posts: 1,956WeTek Support Team
    I'm glad that worked :)

    I found out that "small trick" when trying to config my remote.
    The remote has 2 IR sensors, one close to each power button. The guide tells to point at the middle, but if the emitter is somewhat week, the IR sensor close to the blue power button might not "pick it up" completely.
    So pointing directly to the learning IR you make sure there is no loss in IR transfer :)

    Thank you for the patience

  • wilfortunewilfortune Posts: 26WeTek Community Member
    That makes a lot of sense. Thank you again. I wrote a review on Amazon, and provided a picture of the proper way to align remotes while programming.

    I think I'm going to buy a few more of these ;)
  • wilfortunewilfortune Posts: 26WeTek Community Member
    edited November 7
    Using this guide, I created my own remote.conf.

    I can't quite figure out why this remote will work with some instances of LibreELEC but not others, even if the builds are the same. Tinkerers probably wouldn't mind this challenge, but for most people, an official conf file for this remote (along with some general instructions for installation) should be provided.

    I hope the attached conf may help others. Uploading the conf file via SAMBA is probably the easiest method for most users. LibreELEC's own guide should help you gain access to your box.

    Once you are able to access your box (via SAMBA or SSH), you'll first want to backup the existing remote.conf. It should be located in \\enter_ip_address_here\Configfiles\. Once you've renamed that file (e.g remote.bak.conf), you are then safe to copy over the file within the zip archive I have attached to this post.
  • AnimaAnima Posts: 1,956WeTek Support Team
    Hi

    Libreelec only supports Pro remote IR codes from version 8 and newer.
    If you are using an older version it will not work. That could be the reason, other than that, I can't think of a reason for it not to work.

Sign In or Register to comment.
Help Center

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

© Copyright 2014 - Creative Dreams | Powered by Vanilla
All times are UTC