WeTek Community Forum

problem with "longpress" actions in keymap.xml under LibreELEC (Leia) v8.90.009 ALPHA

MrFloppyMrFloppy Posts: 4WeTek Community Member
I've upgraded from KODI v17.6 to KODI v18 (RC2) using LibreELEC (Leia) v8.90.009 ALPHA and ran into the problem that my previous modified "keymap.xml" located in the "userdata" folder/"keymaps" subfolder does not work anymore with the remote control which was shipped with the WETEK PLAY 2 :-(



I found out that the codes of the remote control buttons did change from KODI v17.6 to 18, so I had to determine them all again with the help of the "Keymap Editor" AddOn. Unfortunately, the "longpress" actions are not working anymore and also prevent the "normal" behaviour of the short pressed key.

Example 1:

<keymap>
<global>
<keyboard>
<key id='232'>ActivateWindow(TVRecordings)</key>
</keyboard>
</global>
</keymap>
When pressing the remote control button 30 in this example it works as it should (-> the window with the TV recordings pops up).

Debug log: https://pastebin.com/9nx2YF9v
At 03:36:17.816 I did press remote control button 30 for the first time


Example 2:
<keymap>
<global>
<keyboard>
<key id='232'>ActivateWindow(TVRecordings)</key>
<key id='232' mod="longpress">ActivateWindow(Favourites)</key>
</keyboard>
</global>
</keymap>
When long pressing the remote control button 30 in this example it does not work as it should (-> the window with the favourites does not pop up), and when short pressing the remote control button 30 the window with the TV recordings also does not pop up....

Debug log: https://pastebin.com/rZDp5ULK
At 03:53:30.332 I did press remote control button 30 for the first time

Please fix it with a new build!

Thank you in advance!

Comments

  • itomicitomic Posts: 47WeTek Community Member
    I have exactly the same problem. Once I navigate to Kodi, buttons 13-16 (see open elec remote control above) stop working. This happened a few weeks ago after Kodi had automatically upgraded to an RC version of Kodi 18. At first I thought that the Wetek Play 2 device had locked up completely. But then I worked out that it was only certain buttons that stopped working. The workaround is to push button 12, which then allows me to use the mouse pointer, which is pretty arduous, but gets the job done eventually.

    Hopefully a future build of Kodi 18 will fix this.
  • ctrlaltcactrlaltca Posts: 50WeTek Community Member
    Not exactly a solution, but you may want to try CoreElec instead: https://coreelec.org/
    It's basically a vanilla libreelec with fixes and customizations for amlogic devices.
    I'm currently running their latest 8.95.6 beta and never experienced problems with the play2 remote.
  • itomicitomic Posts: 47WeTek Community Member
    Thanks for that advice ctrlaltca. I'll give that a go.
  • MrFloppyMrFloppy Posts: 4WeTek Community Member
    @ctrlaltca:

    Well, I've just tried it with a fresh, clean install of "CoreELEC 8.95.6", but unfortunately, the problem with the not working remote control for the WETEK PLAY 2 regarding "longpress" does occure there, too :-(

    And we are not alone, take a look in the CoreELEC forum at the section "remote controllers" https://discourse.coreelec.org/c/coreelec/remote-controllers ...

  • itomicitomic Posts: 47WeTek Community Member
    @MrFloppy Did you get rid of WeOS completely?

    I thought I had (powered on the WP2 with a pin in that tiny hole), CoreElec appeared to install, so straight into Kodi. And my buttons worked! But then when I rebooted the WP2, it booted back into WeOS, no sign of my attempt to intall CoreElec. So I can't have done a clean install, clearly!
  • MrFloppyMrFloppy Posts: 4WeTek Community Member
    @Itomic:

    @itomic:

    Yeah, the buttons do work, but I would like to continue using the "longpress" functionality of the remote control, which gives me the double amount of actions I can map the buttons to - just like it worked without any problem under KODI v17.6, but unfortunately not under KODI v18 anymore! A configuration like this requires manually editing the keymap.xml file located in the "userdata" folder/"keymaps" subfolder (examples are in my first posting above), using the "Keymap Editor" AddOn does not provide this flexibility.

    Anyway, you asked how I installed "CoreELEC (as it was my first time installing a complete "new" OS other than "LibreELEC", I had to google some informations, too):

    - I used a new SDcard for writing the image file to (this way I could go back to "LibreELEC" easily)
    - I followed exactly the instructions at https://coreelec.org/#install and used the recommended image writing software "Rufus" (I had tried another one before, but that did not create the "device-trees" on the SDcard with the required specific file for the WP2 which has to be renamed and copied in its "root" folder)
    - I did NOT use the "pin in that tiny hole" method, I read this is only for recovery operations
    - I did press the "menu" button while powering on, after some time the installation began

    After rebooting "CoreELEC", I'm presented with the option "To boot from nand by holding down the power button" (which then would lead me to the installed version of "Android" from stock under WeOS), but I prefer using my installation on the SDcard ("LibreELEC" on my first SDcard or "CoreELEC" on my second one), so I just wait for KODI to start automatically.

    So to answer your question whether I got rid of WeOS - no, and I did not intend to (despite from the fact that I'm using the underlying "Android" very seldom).
  • MrFloppyMrFloppy Posts: 4WeTek Community Member
    Okay, guys:

    Yesterday I had enough time to look thoroughly through some suggestions I got from a conversation in the LibreELEC forum - and finally I can say it is working with "longpress" actions, too.

    Here's the solution: https://forum.libreelec.tv/thread/13897-problem-with-longpress-actions-in-keymap-xml-under-libreelec-leia-v8-90-009-alph/
  • ctrlaltcactrlaltca Posts: 50WeTek Community Member
    Glad to know you got it working!
  • itomicitomic Posts: 47WeTek Community Member
    Thanks @MrFloppy , I've now achieved the same as you. Although I am tempted to get rid of WeOS completely because, like you, I rarely use the underlyinh Android OS.
  • ohinsaohinsa Posts: 3WeTek Community Member
    This is great That's a great website it really is what I was looking for thank you for sharing!
    shell shockers unblocked
Sign In or Register to comment.
© Copyright 2014 - Creative Dreams | Powered by Vanilla
All times are UTC