WeTek Community Forum

Anyone tried the LibreELEC 9.0 update channel on the WT Core?

petersphilopetersphilo Posts: 7WeTek Community Member
Has anyone tried the LibreELEC 9.0 update channel on the WT Core?
the newest available version as of this writing in this update channel is 8.90.009
These look like beta version numbers..

Has anyone tried this (ideally on a NAND install)?

Any successes and/or failures?

Thank you!
You do not have permission to view polls.


  • roelroel Posts: 4WeTek Community Member
    I tried the 8.90.009 image (alpha), everything I tried worked expect the games, retroplayer crashed and kodi restarted. IR remote worked also, but according the old way, not the new way as described in the wiki. Didn't test from NAND, only sd-card. Will only install to NAND once it is stable.
    BTW there is a new beta version now, didn't test it yet.
  • petersphilopetersphilo Posts: 7WeTek Community Member
    Thank you for your response, it really helps!

    Quick note to the webmaster here: the LetsEncrypt certificate is expired....
  • 303_trancer303_trancer Posts: 3WeTek Community Member

    This is my first post here. I actually installed it yesterday on my core to to see if that gets me to watch netflix. I did only the install of libeelec 9.0 and nothing else yet because I'm still searching what to do to get netflix running on this box...
  • petersphilopetersphilo Posts: 7WeTek Community Member
    @303_trancer: so? is it working?

    As for Netflix, i'm no authority on the matter, but i remember reading somewhere that no official Netflix plugin will ever come to Kodi..
    Maybe on Android, i wouldn't know... But it looks like there will never be a Netflix client on Kodi/OpenELEC/LibreELEC
  • rumax1956rumax1956 Posts: 3WeTek Community Member
    I'm currently using latest LibreELEC (Leia) 9.0.1 MR and I've installed the Netflix plugin following the guide on the official Kodi forum (https://forum.kodi.tv/showthread.php?tid=329767).

    It works.

    But using this plugin only SW decoding with inputstream is possible and the Core is really too underpowered to view Netflix at a decent quality.

    Anything above 360p is simply unwatchable.
  • petersphilopetersphilo Posts: 7WeTek Community Member
    Just FYI..
    i updated my WeTek Core to LibreELEC 9.0.2

    Now it freezes at random moments during playback...
    Also when forwarding video
  • x_Killer_xx_Killer_x Posts: 70WeTek Community Member

    Isn't it better to use OpenElec? More recent imo
  • HovervoHovervo Posts: 52WeTek Community Member
    OpenElec Is Dead the Dev team split and started LibreElec
  • TadeoTadeo Posts: 2WeTek Community Member
    Updated yesterday to 9.0.2 and on 4K resolution/24P its not working (black sreen but device seems to live cause I'm hearing clicking sounds when moving cursor) on 1080P is ok.
Sign In or Register to comment.
© Copyright 2014 - Creative Dreams | Powered by Vanilla
All times are UTC