WeTek Community Forum

No wifi: possible hardware problem

joaopedrotaveirajoaopedrotaveira Posts: 2WeTek Community Member
Hi,

Wireless device not found using LE and fails to "Enable Wifi device" on Android.

dmesg sample from LE available on pastebin link:
https://pastebin.com/NT8EEd9t

What's next?

Comments

  • x_Killer_xx_Killer_x Posts: 66WeTek Community Member
    I remember reading on LibreElec forum that the hub had a problem with wifi on LibreElec.
    Are you using the latest version?

    Hi,

    Wireless device not found using LE and fails to "Enable Wifi device" on Android.

    dmesg sample from LE available on pastebin link:
    https://pastebin.com/NT8EEd9t

    What's next?

    I remember reading on LibreElec forum that the hub had a problem with wifi on LibreElec.
    Are you using the latest version?
  • joaopedrotaveirajoaopedrotaveira Posts: 2WeTek Community Member
    Yes, I'm using latest source of LE to Hub, but the wifi issue also affects android.

    I posted sample of LE dmesg because it was the easyest log available at the moment I made the post.
    My hub can't access wifi device from LE, webOS v3.2 or Android TV v2.4.1.

    On LE dmesg I can notice that wifi device probing it's always failing due to wrong chip ID. This usually means hardware issue. I work with hardware prototyping and this is usually caused by bad wiring or hardware malfunction. The Hub isn't a prototype, thus it must be a hardware malfunction:


    [ 73.969396@2] dhdsdio_probe_attach: unsupported chip: 0xf007
    [ 73.969417@2] dhdsdio_probe: dhdsdio_probe_attach failed
    ...
    [ 87.136365@2] dhdsdio_probe_attach: unsupported chip: 0x7007
    [ 87.136369@2] dhdsdio_probe: dhdsdio_probe_attach failed
    ...
    [ 113.490982@2] dhdsdio_probe_attach: unsupported chip: 0xf044
    [ 113.490987@2] dhdsdio_probe: dhdsdio_probe_attach failed
    ...
    [ 126.657053@2] dhdsdio_probe_attach: unsupported chip: 0xf047
    [ 126.657061@2] dhdsdio_probe: dhdsdio_probe_attach failed
    ...
  • x_Killer_xx_Killer_x Posts: 66WeTek Community Member
    @joaopedrotaveira I know, I was just asking, btw I tested with mine and didn't have any problems
    if your device is still covered by the warranty you can easily get a replacement.
Sign In or Register to comment.
© Copyright 2014 - Creative Dreams | Powered by Vanilla
All times are UTC