WeTek Community Forum

[VIDEO] How to install tvheadend and scan DVB-T channels

AdministratorAdministrator Posts: 355Administrator - WeTek Community Manager, WeTek Community Member
[VIDEO] How to install tvheadend and scan DVB-T channels

Goal of this video tutorial is to teach you how to install tvheadend and scan DVB-T channels on WeTek Play with OpenELEC.

Usually, when scanning for DVB-T channels with tvheadend it is enough to choose your country, and tvheadend will scan all frequencies which are known for your country.

Of course if you know frequency, you can add mux manually by inserting single frequency, and choosing bandwidth.

tvheadend require from user to enter frequency in Hz (hertz), and usually we know frequency in MHz, so for one example 602 MHz in Hz will be 602000000, and 602000000 will be value which we will enter in Frequency (Hz): field in tvheadend. Don't forget to choose bandwidth.

When scanning is done, click on Services tab, and then click on Map All button, from where you can map all channels which will be available on your OpenELEC installation.

For easy setup, take a look at our tutorial on YouTube:

Comments

  • thebearnecessitiesthebearnecessities Posts: 8WeTek Community Member
    Re: [VIDEO] How to install tvheadend and scan DVB-T channels

    I followed this tutorial but scan failed. Should my frequency bedifferent from the vid? I'm in the UK.
  • AdministratorAdministrator Posts: 355Administrator - WeTek Community Manager, WeTek Community Member
    Re: [VIDEO] How to install tvheadend and scan DVB-T channels
    I followed this tutorial but scan failed. Should my frequency bedifferent from the vid? I'm in the UK.

    Hi thebearnecessities,

    Did You selected predefined settings for UK? Also did you enable DVB-T adapter, as maybe you selected DVB-C adapter.

    http://prntscr.com/6r5rgh
  • bejebeje Posts: 12WeTek Community Member
    Can somebody clarify me the mistery: in the youtube tutorial at 1:45 it is jumping in a "new interface". Can somebody tell me which is this interface and how to access it? (sorry I am all new to kodi...)

    Thanks!
  • rot30rot30 Posts: 850WeTek Community Member
    That it is the tvheadend web interface and you can access it by using a web browser from a PC that is on the same LAN as the WeTek Play.
    Just type into your browsers address bar:
    the.ip.of.openelec:9981
    
    Or
    openelec.local:9981
    
    You can see the WeTek Play's current IP address under:
    SYSTEM -> System info -> Summary
    
  • harvey28harvey28 Posts: 1WeTek Community Member
    I've done what you suggested typing 192.168.0.22:9981 (the Play's IP) into my PC browser on the same LAN, and it won't connect. Any ideas?

    Also, I don't have a TV section on the home page. Anyone know why?
  • rot30rot30 Posts: 850WeTek Community Member
    Thank you for choosing the WeTek Play and registering on the wetekforums.

    Have you followed the video tutorial?
    Have you made sure you turned off VDR or any other PVRs except tvheadend?
    What version of OpenELEC for the WeTek Play are you using?
  • JamrimanJamriman Posts: 3WeTek Community Member
    Just got the openelec version. All configurations are different. Nothing matches the tutorials. Tried to scan channels with VDR Wirbelscan control, it just hangs no matter what is set. I have a ATSC tuner in USA.
  • rot30rot30 Posts: 850WeTek Community Member
    Thank you for choosing the WeTek Play and registering on the wetekforums.

    Try following the instructions from this thread.
  • jean.cayronjean.cayron Posts: 30WeTek Community Member
    Hello.
    I'm on a Wetek openELEC box. I made the update to 5.95.3 and followed the tutorial.
    Everything works for the configuration but I can't access to the TV via Kodi:
    - Every time I reboot the client is disabled and I got an message that I have to enable a TV client.
    - There is no TV entry in the menu.

    Is this a known bug or miss I something?

    NB: I tried VDR as well but I could not access to Client specific settings as I could in oE 5.0.8 and I had the same problem that the addon disabled itselfs at reboot.
    Is this related with https://tvheadend.org/issues/3026 ?
  • jean.cayronjean.cayron Posts: 30WeTek Community Member
    Hello.
    I'm on a Wetek openELEC box. I made the update to 5.95.3 and followed the tutorial.
    Everything works for the configuration but I can't access to the TV via Kodi:
    - Every time I reboot the client is disabled and I got an message that I have to enable a TV client.
    - There is no TV entry in the menu.

    Is this a known bug or miss I something?

    NB: I tried VDR as well but I could not access to Client specific settings as I could in oE 5.0.8 and I had the same problem that the addon disabled itselfs at reboot.
  • MC117MC117 Posts: 3,707Administrator - WeTek Community Manager
    [USER="12755"]jean.cayron[/USER] Please take a look at this tutorial

    Best Regards

  • RE:RE: Posts: 5WeTek Community Member
    Hi,

    I received my Wetek OpenElec box last Tuesday. I followed the tutorial to install and set-up tvheadend. My problem is that the DVB-T scan does not find any channel at all.

    I'm located in Munich, Germany and tried to set the Muxes to "Germany: de-Bayern". Still do all the channels show FAIL.

    Connecting the antenna directly to the TV the scan find more than 16 channels. I now suspect a h/w failure in the box. Does anybody have similar problems? Any hints?

    RE
  • jean.cayronjean.cayron Posts: 30WeTek Community Member
    [USER][/USER]

    Worked great. I restored my old configuration of tvheadend. But I wish Wetek or openELEC would offer a solution out of the box or more strait forward (why not an extension that does install everything described in the tutorial?).
  • NukiNuki Posts: 5WeTek Community Member
    i got my box yesterday. tried using the vdr add-on but it didn't find any channels so i installed tvheadend and accessed it from my laptop. for some reason it does not recognize any tv adapter on the box. the folder is empty :(

    EDIT: just now found this http://wetekforums.com/vb5/forum/wetek-play/linux/openelec/tutorials-aa/13598-tutorial-why-my-tuner-isn-t-availabe-on-tvheadend
    will try
  • LinusLinus Posts: 35WeTek Community Member
    Hello, just to say that i do not have any problem to scan all the channel with vdr (the pluggin that you have made) or with tvheaden.

    But in fact on the tutorial, there is an other way for the muxe.

    Normally, when you choose the tuner in the first page, you could choose some default muxe, for exemple, i could choose "France_ALL" that will add all the french muxe, and after i could scann all. That's easier then add manually the 7/8 muxe that are around us.
  • umanoidumanoid Posts: 13WeTek Community Member
    Re: [VIDEO] How to install tvheadend and scan DVB-T channels



    Hi thebearnecessities,

    Did You selected predefined settings for UK? Also did you enable DVB-T adapter, as maybe you selected DVB-C adapter.

    http://prntscr.com/6r5rgh

    Similar problems for me with UK broadcasts. Again the question is should I be using a different frequency as I am not getting ANY HD channels scanned. BTW What pre-defined settings I see none in the box you point to.

    I am spending hours setting up something as simple as a TV signal , as someone else suggested maybe Wetek should provide some of this stuff out of the box.
  • NE0NE0 Posts: 808WeTek Community Member
    [USER="13368"]umanoid[/USER]

    Take a look here:
  • umanoidumanoid Posts: 13WeTek Community Member
    NE0 wrote: »
    [USER="13368"]umanoid[/USER]

    Take a look here:

    Well that failed miserably. They just stay pending for ever. No scan at all. Then I find every time the box reboots TVHeadend client is not installed and I have to go through the whole business again. Now I have tried different OE versions most recently Wetek OE ver5.08 but can't see any option to install Tvheadend server on that. As it is this box does nothing after 3 days of trying I have NO Tv service.
  • GekkonGekkon Posts: 36WeTek Community Member
    umanoid wrote: »

    Well that failed miserably. They just stay pending for ever. No scan at all. Then I find every time the box reboots TVHeadend client is not installed and I have to go through the whole business again. Now I have tried different OE versions most recently Wetek OE ver5.08 but can't see any option to install Tvheadend server on that. As it is this box does nothing after 3 days of trying I have NO Tv service.

    WeTek OpenELEC Box
    Similarly, I spent several days in vain.
    Openelec 6.0 hangs!
    As a result, I set WeTek OS v.1.1.6
Sign In or Register to comment.
© Copyright 2014 - Creative Dreams | Powered by Vanilla
All times are UTC